Bug 829728 - Crash on reload with persistent search enabled
Crash on reload with persistent search enabled
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: bind-dyndb-ldap (Show other bugs)
6.4
Unspecified Unspecified
high Severity unspecified
: rc
: ---
Assigned To: Adam Tkac
Namita Soman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-07 08:39 EDT by Petr Spacek
Modified: 2015-05-20 11:57 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 03:58:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Spacek 2012-06-07 08:39:42 EDT
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/bind-dyndb-ldap/ticket/78

Steps to reproduce:

1. enable persistent search 

2. run following commands:
{{{
export KRB5_KTNAME="/etc/named.keytab"
named -g -u named -d 0
rndc reload
}}}
Comment 4 Namita Soman 2012-11-16 14:29:07 EST
Verified using:
ipa-server-3.0.0-8.el6.x86_64


::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
:: [   LOG    ] :: bz829728 - Crash on reload with persistent search enabled
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

:: [13:40:20] ::  Executing: export KRB5_KTNAME="/etc/named.keytab"
:: [   PASS   ] :: export KRB5_KTNAME
:: [13:40:20] ::  Executing: named -u named -d 0
:: [   PASS   ] :: run named as user named
:: [13:40:21] ::  Executing: rndc reload
server reload successful
:: [   PASS   ] ::  rndc reload was successful
:: [13:40:22] ::  Executing: service named status
version: 9.8.2rc1-RedHat-9.8.2-0.16.rc1.el6
CPUs found: 2
worker threads: 2
number of zones: 22
debug level: 0
xfers running: 0
xfers deferred: 0
soa queries in progress: 0
query logging is OFF
recursive clients: 0/0/1000
tcp clients: 0/100
server is up and running
named (pid  10220) is running...
:: [   PASS   ] :: Verifying that named is running
'e05f68c4-683d-4e04-90ff-65af094b41fc'
bz829728-Crash-on-reload-with-persistent-search-enabled result: PASS
   metric: 0
   Log: /tmp/beakerlib-9193278/journal.txt
    Info: Searching AVC errors produced since 1353091218.63 (Fri Nov 16 13:40:18 2012)
     Searching logs...
     Info: No AVC messages found.
 Writing to /mnt/testarea/tmp.zW6ING
:
   AvcLog: /mnt/testarea/tmp.zW6ING
Comment 6 errata-xmlrpc 2013-02-21 03:58:16 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0359.html

Note You need to log in before you can comment on or make changes to this bug.