Bug 829748 - GlusterFS: System should be aware that clients are connected
GlusterFS: System should be aware that clients are connected
Status: CLOSED CURRENTRELEASE
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
unspecified
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Kanagaraj
Sudhir D
gluster, storage
:
Depends On:
Blocks: 825285
  Show dependency treegraph
 
Reported: 2012-06-07 09:32 EDT by Daniel Paikov
Modified: 2016-04-18 06:05 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-10 03:44:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Paikov 2012-06-07 09:32:18 EDT
* Stop a volume while NFS client is connected.
* Remove a volume while NFS client is connected.
* NFS client freezes because the mountpoint disappears under its feet.
* The system should be aware that clients are connected and block stopping and/or removal of volumes that are in use.
Comment 2 Shireesh 2012-06-07 10:19:26 EDT
As soon as you "stop" a volume to which NFS client is connected, it is no more accessible to the clients, so "remove" part can be out of question for this bug, as we don't allow removing a volume if it's in "UP" status.

We should not prevent the user from stopping such volumes, but provide a sufficient warning and ask for confirmation. Currently the confirmation prompt says

"Are you sure want to stop the following Volume(s)?"

We should add more text below saying "Stopping a volume will make its data inaccessible." (Exactly same as the warning shown by GlusterFS CLI)
Comment 3 Kanagaraj 2012-06-11 07:26:04 EDT
Confirmation popup modified to add a Note: in the bottom to explain the result of the action(Stop or Remove).

The message will be same as the glusterfs warning while performing the action.

Patch : http://gerrit.ovirt.org/#/c/5230/
Comment 4 Daniel Paikov 2012-06-18 05:49:31 EDT
Checked on rhsc-2.0.techpreview1-0.scratch.

Note You need to log in before you can comment on or make changes to this bug.