Bug 829780 - RFE ability to add custom anaconda part commands in plain text to job xml
RFE ability to add custom anaconda part commands in plain text to job xml
Status: CLOSED DUPLICATE of bug 1198881
Product: Beaker
Classification: Community
Component: scheduler (Show other bugs)
0.8
All All
medium Severity medium (vote)
: ---
: ---
Assigned To: beaker-dev-list
Kickstart
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-07 10:25 EDT by John Brier
Modified: 2016-02-12 00:34 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-12 00:34:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Brier 2012-06-07 10:25:25 EDT
Description of problem:

from http://post-office.corp.redhat.com/archives/beaker-user-list/2012-June/msg00031.html

==
I think it would be a useful feature to be able to supply your own 
Anaconda part commands in the job. As plain text, not XML. (It's been 
discussed on this list before, I think...)

Maybe we could add an attribute raw="True" meaning you want to pass the 
Anaconda commands directly instead of XML, and another attribute 
suppress_defaults="True" meaning you don't want the default root, boot, 
and swap. Then you could have:

    <partitions raw="True" suppress_defaults="True">
        part / --fstype ext4 --size=100 --grow
        ...
    </partitions>

with whatever crazy part commands you want. Then it would be up to you 
to make sure they are valid and installable
==
Comment 1 Bill Peck 2012-06-07 10:33:18 EDT
I agree with this bz 100%  Although I'm not sure we need the raw="True", I don't think it makes sense to store this in xml when we should just use kickstart language.  Basically it would always be raw, but the suppress defaults makes sense.
Comment 2 Nick Coghlan 2012-10-17 00:38:21 EDT
Bulk reassignment of issues as Bill has moved to another team.
Comment 5 Dan Callaghan 2016-02-12 00:34:03 EST
This is a dupe of bug 1198881. The solution we settled on there was ks_meta="no_autopart" to suppress the Beaker-supplied autopart command, then any desired partitioning commands can be placed in a <ks_append/>.

*** This bug has been marked as a duplicate of bug 1198881 ***

Note You need to log in before you can comment on or make changes to this bug.