Bug 829788 - Manually created job on OpenShift Jenkins won't build
Manually created job on OpenShift Jenkins won't build
Status: CLOSED NOTABUG
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Bill DeCoste
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-07 10:46 EDT by Pete Muir
Modified: 2015-05-14 18:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-10 17:23:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pete Muir 2012-06-07 10:46:30 EDT
Description of problem: 

On manually creating a new job on a jenkins node, this error occurs in the system log

Jun 7, 2012 9:56:50 AM hudson.plugins.openshift.OpenShiftCloud provision
INFO: Provisioning new node for workload = 2 and label = null
Jun 7, 2012 9:56:50 AM hudson.triggers.SafeTimerTask run
SEVERE: Timer task hudson.slaves.NodeProvisioner$NodeProvisionerInvoker@8719e failed
java.lang.UnsupportedOperationException: No Label
	at hudson.plugins.openshift.OpenShiftCloud.provision(OpenShiftCloud.java:461)
	at hudson.slaves.NodeProvisioner.update(NodeProvisioner.java:227)
	at hudson.slaves.NodeProvisioner.access$000(NodeProvisioner.java:51)
	at hudson.slaves.NodeProvisioner$NodeProvisionerInvoker.doRun(NodeProvisioner.java:308)
	at hudson.triggers.SafeTimerTask.run(SafeTimerTask.java:54)
	at java.util.TimerThread.mainLoop(Timer.java:534)
	at java.util.TimerThread.run(Timer.java:484)

Version-Release number of selected component (if applicable):

Production on 7th June 2012

How reproducible:

Always

Steps to Reproduce:
1. Create a new freestyle project, manually
2. Try to build it


Additional info:

The issue is caused because no label expression is provided

Workaround:

Add a label expression as created by the jenkins-client - perhaps - still testing ;-)
Comment 1 Bill DeCoste 2012-07-11 21:03:33 EDT
You need a label - this becomes the name of the builder. This is as designed.

Note You need to log in before you can comment on or make changes to this bug.