Bug 829801 - [abrt] java-1.7.0-openjdk-devel-1.7.0.3-2.1.fc17.6: Process /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.3/bin/java was killed by signal 6 (SIGABRT)
[abrt] java-1.7.0-openjdk-devel-1.7.0.3-2.1.fc17.6: Process /usr/lib/jvm/java...
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: java-1.7.0-openjdk (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Deepak Bhole
Fedora Extras Quality Assurance
abrt_hash:1c4de2b9b9368d5d1da301b81a4...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-07 11:15 EDT by Vincent Tam
Modified: 2012-06-21 16:32 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-21 16:32:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (127.19 KB, text/plain)
2012-06-07 11:15 EDT, Vincent Tam
no flags Details
File: maps (41.21 KB, text/plain)
2012-06-07 11:15 EDT, Vincent Tam
no flags Details
File: dso_list (8.30 KB, text/plain)
2012-06-07 11:15 EDT, Vincent Tam
no flags Details
File: open_fds (6.40 KB, text/plain)
2012-06-07 11:15 EDT, Vincent Tam
no flags Details

  None (edit)
Description Vincent Tam 2012-06-07 11:15:10 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        /usr/lib/jvm/java/bin/java -Djdk.home=/usr/lib/jvm/java -classpath /usr/local/netbeans-7.1.2/platform/lib/boot.jar:/usr/local/netbeans-7.1.2/platform/lib/org-openide-modules.jar:/usr/local/netbeans-7.1.2/platform/lib/org-openide-util.jar:/usr/local/netbeans-7.1.2/platform/lib/org-openide-util-lookup.jar:/usr/local/netbeans-7.1.2/platform/lib/locale/boot_ja.jar:/usr/local/netbeans-7.1.2/platform/lib/locale/boot_pt_BR.jar:/usr/local/netbeans-7.1.2/platform/lib/locale/boot_ru.jar:/usr/local/netbeans-7.1.2/platform/lib/locale/boot_zh_CN.jar:/usr/local/netbeans-7.1.2/platform/lib/locale/org-openide-modules_ja.jar:/usr/local/netbeans-7.1.2/platform/lib/locale/org-openide-modules_pt_BR.jar:/usr/local/netbeans-7.1.2/platform/lib/locale/org-openide-modules_ru.jar:/usr/local/netbeans-7.1.2/platform/lib/locale/org-openide-modules_zh_CN.jar:/usr/local/netbeans-7.1.2/platform/lib/locale/org-openide-util_ja.jar:/usr/local/netbeans-7.1.2/platform/lib/locale/org-openide-util-lookup_ja.jar:/usr/local/netbeans-7.1.2/platform/lib/locale/org-openide-util-lookup_pt_BR.jar:/usr/local/netbeans-7.1.2/platform/lib/locale/org-openide-util-lookup_ru.jar:/usr/local/netbeans-7.1.2/platform/lib/locale/org-openide-util-lookup_zh_CN.jar:/usr/local/netbeans-7.1.2/platform/lib/locale/org-openide-util_pt_BR.jar:/usr/local/netbeans-7.1.2/platform/lib/locale/org-openide-util_ru.jar:/usr/local/netbeans-7.1.2/platform/lib/locale/org-openide-util_zh_CN.jar:/usr/lib/jvm/java/lib/dt.jar:/usr/lib/jvm/java/lib/tools.jar -Dnetbeans.dirs=/usr/local/netbeans-7.1.2/nb:/usr/local/netbeans-7.1.2/bin/../ergonomics:/usr/local/netbeans-7.1.2/ide:/usr/local/netbeans-7.1.2/java:/usr/local/netbeans-7.1.2/apisupport:/usr/local/netbeans-7.1.2/bin/../webcommon:/usr/local/netbeans-7.1.2/websvccommon:/usr/local/netbeans-7.1.2/bin/../enterprise:/usr/local/netbeans-7.1.2/bin/../mobility:/usr/local/netbeans-7.1.2/profiler:/usr/local/netbeans-7.1.2/bin/../python:/usr/local/netbeans-7.1.2/bin/../php:/usr/local/netbeans-7.1.2/bin/../identity:/usr/local/netbeans-7.1.2/harness:/usr/local/netbeans-7.1.2/bin/../cnd:/usr/local/netbeans-7.1.2/bin/../dlight:/usr/local/netbeans-7.1.2/bin/../groovy:/usr/local/netbeans-7.1.2/bin/../extra:/usr/local/netbeans-7.1.2/bin/../javacard:/usr/local/netbeans-7.1.2/javafx: -Dnetbeans.home=/usr/local/netbeans-7.1.2/platform -Dnetbeans.importclass=org.netbeans.upgrade.AutoUpgrade -Dnetbeans.accept_license_class=org.netbeans.license.AcceptLicense -XX:MaxPermSize=384m -Xmx650m -client -Xss2m -Xms32m -XX:PermSize=32m -Dapple.laf.useScreenMenuBar=true -Dapple.awt.graphics.UseQuartz=true -Dsun.java2d.noddraw=true -Dsun.zip.disableMemoryMapping=true -XX:+HeapDumpOnOutOfMemoryError -XX:HeapDumpPath=/home/owner/.netbeans/7.1.2/var/log/heapdump.hprof org.netbeans.Main --userdir /home/owner/.netbeans/7.1.2 --branding nb
comment:        Using NetBeans 7.1.2 GUI feedback to edit JTable
crash_function: pthread_cond_wait@@GLIBC_2.3.2
executable:     /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.3/bin/java
kernel:         3.4.0-1.fc17.i686
pid:            1616
pwd:            /home/owner
time:           Thu 07 Jun 2012 11:08:41 PM HKT
uid:            1000
username:       owner

backtrace:      Text file, 130246 bytes
dso_list:       Text file, 8504 bytes
maps:           Text file, 42202 bytes
open_fds:       Text file, 6556 bytes

build_ids:
:0613b3e55e3ef969fe4f2a918929f4ca823e1ac3
:9aea670864d2a34a222fd110376f7946b702de7c
:7f3c4b2fc7f49a8e50f936b1435bfcf785b29191
:5ec6e8b3409fb725cb67000dfd969937f2087951
:0a1a8bf5237a71d763d23520783335c8fe6c31dd
:57d6de5ff5536ed125c804f036da93c46399c6e4
:0c11a3a3e3f485f800670fab60e9c0246db09271
:c37ce5a56ac9116ef3203d075293c839e22aadc9
:8942f83f6428f92b3e2b20fd88874d1554ab96f2
:4bd9cd3a78fa841a2bcf0df8c7e838b80cccd5f3
:a96cfe9e9cdc55f989a314b934ad9945aa11602a
:92aaf9e3a33962226af01da69620e9be799859d4
:55851675129865460c90f723a5c44f3da8482e5b
:35b89ab09e065e4da8f417312ca2f1105efc0a01
:38cf10270d825cdb758d459e010ed3b5fbafe18d
:848a04e2a6ce321422123dd4369d8fff2214d349
:8d3308331c237b31f5e500d73e249edd53676aec
:62150f38cf11baa1966ed86cf2c4839bd029b0c8
:c48bdbb2542d5d7ce5b081f57915ca6164dd70b5
:e9363a6b468d459c7e4cb0d9757079106b3a882c
:9eed24db9f590729acc9618917844b0e88e0fd5d
:fad91ac353e3532099b38d4dffada3e91cf97fa3
:702964f64f5758b4dd279b04db2a8e47eece7084
:ff7cd1ed03a87c0eb8d530d46fac1fcec5caf45d
:ccd17c03940a8cb54bb2f9c6f6d76626976fccf7
:0104836c3350fa74bdd7ae9815eb65b8b985afc7
:15beedcb299b506c9c6a09bdfed67a02095644a5
:b39942900ac2f1d95ab013a2ae9bb257f677d2e1
:5b5557b5b0427930b220a00961393e29809c42f0
:7468ba793c595989f2e6a123e4a2af42f38ef0fe
:0f22adfaabe11cef7a87e5cc3e66d522ec81800d
:0db1085b6f5f26681999bf8762e7374bb8179395
:6827db64bf037f6de97ac9f37d50f32f343930a4
:757d0ed5f496fc377d8558caf8987cefa4679f96
:1d6d247cb1c1dc86b34ab960d58c82d7cce35e15
:073a6e8be3691c9090d7e8063df1b719658a25a2
:bdefcd1310b1f24530d799dc0128edd358eb3331
:f1c305c893872fa4a0e7d77f388f2833974a5433
:de77b9c1ea8f88712017f4d99ad3d86726f54023
:0192dd2785a5ee3ae8c4e920cb320c702385d4ef
:4917bcde22f3be7892a0289b37cf7dfc987c8474
:bef638b29fdf84e92e8f33383eb8adb175128188
:c4671f28d8289507d4535e0a1484926b7408d39a
:346c7f8a791cd1b7be07bfff6f849d658d506a17
:4766d96e19faf4e874c15cfb89feba118b91c6e6
:1bf5714f8c058dd66f3e5dd3afb6550e8a0594b9
:4c23c393ed8b8565bd8e90d5b57a868ba0ccfab3
:fb2937738211d999ca6946e653412fbfabb1f613
:024368aa1f00c8da609a2d687462dfbfe81aba8e
:657bed8df5cfda1d7eb24a25a043cfbdf228b933
:c231c23d958aa42bb98f000cee5a9a11e090249d
:f13e5fa699a7129ee3080ddeb31558ef7578cddb
:cdf4a22ae78a77d387cfbba3d667dba692429114
:2db83a4c3dc4ba607b77e73639ac847081193f8c
:0cfbae8de78ad475c40fd81bd08d947b628c2b90
:c8c155acc515416efd9d0e407ec2667e30f58083
:327661a5f401b69a985e63c374da3357fb7bd155
:c7112059d672dfb1b17ed4be88fa89f30b547841
:1a6724864a20a8124878efd04edfc1b05ef3d5c3
:25db3aa1d5ba511ce1f2615c8b5995285af564b1
:4fcc6506e9b218b3fefd1c1f30e3ae450843902e
:c9666f5e43b3b03d782acadda76ae3074095c8a4
:e699e77e64f6beae43814629738e5365acfff968
:019e42ad205179335b27f2a79a873fda88ed21a3
:de9d7cbf664acdddd5f97fc560de561108ec67e7
:b67d1ea991c450423fd28c5d05d9551eaacd4496
:d44eca373263d7abb445ddd5bad3dafbccd8cfed
:3e8db068ebbfae69654767b42d9b0475c53121e7
:7e9d9994489152b4b37aa5bee934e9f2c8309a54
:c25f4a34816c8918d5cce3f8b7a851948c6db023
:953d0b9c6eb7c9454930ffcc91196fb9c9d8dc20
:030b5d1726ecd29df95bdeeff0b2d62043833fee
:d0b2ee750bf29544a82c25b03f3fe22086c6c4be
:0b819ed1b9dae71a48c4472b26cb99f565163722
:9ff154685b04583c95ef0f393e8be81e3c51ca7b
:75901b80d2dac1e6eb7ce9c4b8446d9190d4896a
:abcfe6b280fcee6f1f127d40d8f54e6b4d896f5a
:4723ea68ac0f3366ffaefee6b60b82b1aa2ea5e4
:4a18cece7105bb73a4f2c3ad540803eb237e7543
:315a93619a0d4725692da2ddcf052d5b38e40e3e
:acccee84fefeebf82dea74d95ce0369573298fe3
:46971db1d5d4e912d605ef354050fafd170dca18
:88355dd86bb6db28d6805ab8d9dc0c0f3886e721
:b23f7b89bf3bebd443fa7cfdfa98b6e00c0f8d33

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/owner/2

core_backtrace:
:741b026cb8260b7f9f82dbbdb072aa78a206633f 0x416 __kernel_vsyscall linux-gate.so.1 -
:f13e5fa699a7129ee3080ddeb31558ef7578cddb 0x2e95f raise libc.so.6 -
:f13e5fa699a7129ee3080ddeb31558ef7578cddb 0x302b3 abort libc.so.6 -
:b67d1ea991c450423fd28c5d05d9551eaacd4496 0x36df99 - libjvm.so -
:b67d1ea991c450423fd28c5d05d9551eaacd4496 0x45d5cb - libjvm.so -
:b67d1ea991c450423fd28c5d05d9551eaacd4496 0x45dcc9 - libjvm.so -

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=2
:HOSTNAME=014199203162.ctinets.com
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:GIO_LAUNCHED_DESKTOP_FILE_PID=1402
:GPG_AGENT_INFO=/run/user/owner/keyring-J4sA4k/gpg:0:1
:SHELL=/bin/bash
:TERM=dumb
:HISTSIZE=1000
:GJS_DEBUG_OUTPUT=stderr
:GNOME_KEYRING_CONTROL=/run/user/owner/keyring-J4sA4k
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:IMSETTINGS_MODULE=none
:USER=owner
:SSH_AUTH_SOCK=/run/user/owner/keyring-J4sA4k/ssh
:USERNAME=owner
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1029,unix/unix:/tmp/.ICE-unix/1029
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/netbeans-7.1.2.desktop
:MAIL=/var/spool/mail/owner
:PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/home/owner/.local/bin:/home/owner/bin
:DESKTOP_SESSION=gnome
:QT_IM_MODULE=xim
:PWD=/home/owner
:XMODIFIERS=@im=none
:J2D_PIXMAPS=shared
:GNOME_KEYRING_PID=1025
:LANG=en_US.utf8
:GDM_LANG=en_US.utf8
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:XDG_SEAT=seat0
:HOME=/home/owner
:SHLVL=2
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:LOGNAME=owner
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-ozexyXCOsb,guid=3186e4d005fc440d31dc4fbb00000021
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/owner
:DISPLAY=:0
:XAUTHORITY=/var/run/gdm/auth-for-owner-VqF1zT/database
:_=/usr/lib/jvm/java/bin/java

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 25873                processes 
:Max open files            4096                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       25873                25873                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

var_log_messages:
:Jun  5 15:18:37 014199203162 yum[4662]: Installed: 1:java-1.7.0-openjdk-devel-1.7.0.3-2.1.fc17.6.i686
:Jun  7 23:08:48 014199203162 abrt[2063]: Saved core dump of pid 1616 (/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.3/bin/java) to /var/spool/abrt/ccpp-2012-06-07-23:08:41-1616 (413536256 bytes)
Comment 1 Vincent Tam 2012-06-07 11:15:17 EDT
Created attachment 590224 [details]
File: backtrace
Comment 2 Vincent Tam 2012-06-07 11:15:19 EDT
Created attachment 590225 [details]
File: maps
Comment 3 Vincent Tam 2012-06-07 11:15:22 EDT
Created attachment 590226 [details]
File: dso_list
Comment 4 Vincent Tam 2012-06-07 11:15:24 EDT
Created attachment 590227 [details]
File: open_fds
Comment 5 Deepak Bhole 2012-06-07 11:54:00 EDT
Is this error reproducible or was it one time?
Comment 6 Vincent Tam 2012-06-09 11:25:04 EDT
Sorry for my late reply. I haven't encountered a collapse of NetBeans 7.1.2 for the second time so it was one time.
I was writing a Java GUI using the visual feedback feature in NetBeans. The JFrame contains a JTable. I had written some lines of code for jButton*ActionPerformed method before click the "Design" button for visual editing of the JTable in the frame. I right clicked the JTable and a menu poped up. Then I selected "Properties". I couldn't remember what I'd click after that. Finally, the whole IDE collapsed and abrt prompted me to report the collapse of NetBeans to this Bugzilla.
Thanks for your attention and I haven't seen any problem while running NetBeans 7.1.2 since then.
Comment 7 Deepak Bhole 2012-06-21 16:32:16 EDT
Okay,. I am going to close this. Please feel free to re-open if it becomes reproducible again.

Note You need to log in before you can comment on or make changes to this bug.