Bug 829808 - Can't create a volume with the same remote directories after deleting one
Can't create a volume with the same remote directories after deleting one
Status: CLOSED DUPLICATE of bug 812214
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
3.3.0
All Linux
unspecified Severity high
: ---
: ---
Assigned To: krishnan parthasarathi
:
: 829811 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-07 11:20 EDT by CyD
Modified: 2015-11-03 18:04 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-08 06:39:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description CyD 2012-06-07 11:20:44 EDT
Description of problem:

When deleting a volume using the CLI, you can't directly re-create a volume with the same parameters of remote partitions to use.

Getting an error saying that the volume is already used


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Create a volume on a blank install of Gluster FS : sudo gluster volume create  toto xxx.xxx.xxx.xxx:/titi xxx.xxx.xxx.xxx:/titi

2. Delete the volume : sudo gluster volume delete toto (yes)

3. Verify that the volume has been destroyed : sudo gluster volume info

4. Create the same volume sudo gluster volume create  toto xxx.xxx.xxx.xxx:/titi xxx.xxx.xxx.xxx:/titi
  
Actual results:

Error : /titi or a prefix name is already part of a volume

Expected results:

Volume correctly re-created.

Additional info:

After deep analysis and quite lots of time, some attributs were still defined on /titi folder on all machines.

Seen using the following command on each machines :

sudo getfattr --absolute-names -m .  -d -e hex /titi

Corrected using the following command with all attributs found :

sudo setfattr -x "xxx" /titi

Looks like the CLI isn't deleting the volume correctly...
Comment 1 Niels de Vos 2012-06-07 11:28:21 EDT
*** Bug 829811 has been marked as a duplicate of this bug. ***
Comment 2 Niels de Vos 2012-06-07 11:31:57 EDT
This is currently intended behaviour. See http://review.gluster.com/781

As this 'problem' seems to happen a lot, it might be a good idea to have the xattrs removed when a brick is removed from a volume, or the volume is deleted.
Comment 3 CyD 2012-06-07 11:35:18 EDT
Actually, I didn't even heard about this script on the Net while searching for a solution, it could be documented somewhere or highlighted in the manual, but it could be pretty interesting to be a native behaviour.

If you want to keep this feature apart, could you please document it in the manual in order to users to know that they wont be able to re-create a volume afterward, unless they run the script.

Thanks for your fast answer
Comment 4 krishnan parthasarathi 2012-06-08 06:39:03 EDT

*** This bug has been marked as a duplicate of bug 812214 ***

Note You need to log in before you can comment on or make changes to this bug.