Bug 829812 - [RFE] Add Explicit Unset Command & Unique String to release Module
[RFE] Add Explicit Unset Command & Unique String to release Module
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: William Poteat
Entitlement Bugs
: FutureFeature, Reopened
Depends On:
Blocks: 827225
  Show dependency treegraph
 
Reported: 2012-06-07 11:22 EDT by Matt Reid
Modified: 2013-01-07 22:54 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:54:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Reid 2012-06-07 11:22:18 EDT
Description of problem:
Currently to remove a preference for service level or release, a user must type in --set "" or --set=, which returns a message of "Release set to:" and "Service level preference not set". I think we should have a unique string for unsetting the preference, something like "Release preference unset", and then if they do --show on an unset preference, it displays "Release preference not set". Saying it wasn't set makes it sound like the command was ignored because something went wrong, so while that works fine for --show, I don't think it fits for --set.

We should implement "release --unset" to remove their preference without having to know they should set it to be blank.

Adding in an explicit command also lets us expose it in --help, so that it is discoverable. As is, they would need to read documentation (assuming we explained it somewhere) to figure out they unset it by setting it.

Version-Release number of selected component (if applicable):
sub-man 1.0.2-1.git.82.94602c6

Additional info:
BZ 829803 for same changes to service-level
Comment 1 William Poteat 2012-06-07 11:59:04 EDT
The --unset for release should result in an empty string sent to the backend server for release. The server should then interpret that value to null for persistence.
Comment 2 Bryan Kearney 2012-06-07 17:05:59 EDT

*** This bug has been marked as a duplicate of bug 829803 ***
Comment 4 RHEL Product and Program Management 2012-06-18 13:07:31 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 5 Shwetha Kallesh 2012-06-26 02:19:13 EDT
Verified!

RPM version:
[root@dhcp201-196 ~]# rpm -qa | grep subscription-manager
subscription-manager-migration-data-1.11.1.1-1.git.2.c7fbafe.el5
subscription-manager-gui-1.0.4-1.git.35.f97af2b.el5
subscription-manager-firstboot-1.0.4-1.git.35.f97af2b.el5
subscription-manager-migration-1.0.4-1.git.35.f97af2b.el5
subscription-manager-1.0.4-1.git.35.f97af2b.el5


[root@dhcp201-196 ~]# subscription-manager release --help | grep unset
  --unset               unset the release for this system
[root@dhcp201-196 ~]# subscription-manager release --unset
Release preference has been unset
Comment 7 errata-xmlrpc 2013-01-07 22:54:40 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.