Bug 82982 - xrandr resolution changes require VC flip to activate completely
xrandr resolution changes require VC flip to activate completely
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
http://bugs.xfree86.org//cgi-bin/bugz...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-29 01:08 EST by Chris Ricker
Modified: 2007-04-18 12:50 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-31 21:12:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X config (1.91 KB, text/plain)
2003-01-29 01:09 EST, Chris Ricker
no flags Details
X log (37.07 KB, text/plain)
2003-01-29 01:10 EST, Chris Ricker
no flags Details

  None (edit)
Description Chris Ricker 2003-01-29 01:08:40 EST
Playing with xrandr on my beat-up old laptop (Trident Cyberblade card, lcd
hard-locked at 1024x768 resolution only)

I start out in 1024x768x75 and then see what else is available:

[kaboom@skuld kaboom]$ xrandr -q
 SZ:    Pixels          Physical       Refresh
*0   1024 x 768    ( 347mm x 260mm )  *75   70   60  
 1    800 x 600    ( 347mm x 260mm )   75   72   60   56  
 2    640 x 480    ( 347mm x 260mm )   75   72   60  
 3    832 x 624    ( 347mm x 260mm )   74  
Current rotation - normal
Current reflection - none
Rotations possible - normal 
Reflections possible - none
[kaboom@skuld kaboom]$ 

So then I switch to a lower resolution (xrandr -s 1). It correctly shrinks.
Since my lcd is hardlocked at 1024x768, it just displays as an 800x600 window w/
a 1024x768 border (as expected). It doesn't center the 800x600 w/in the 1024x768
frame though -- instead it anchers the 800x600 display at (0,0). No big deal,
just different than what I might have expected / what usually happens when
running lower res on a fixed res lcd....

At any rate, I then switch back (xrandr -s 0). It appears to go back to
1024x768, but the desktop is really still only 800x600.  The last 224 pixels
(from 576 to 800) are simply copied and displayed again as pixels 801 - 1024.
For example, if I move my mouse to about (700,10), it shows up as (700,10) and
as (924,10). Ditto for dialog boxes, stuff in the gnome panel at the bottom of
the screen, etc.

To make things weirder:

* its just the horizontal stretching that's screwed. Vertically, everything's
fine (going from 600 to 768 actually did go to 768, rather than copying the
bottom 168 pixels and displaying them twice)
* I tried using the gimp to do a screen capture of the effect. In the screen
capture, everything's completely normal

If I flip to a text VC and then back to X, everything straightens out, and I get
real 1024 resolution
Comment 1 Chris Ricker 2003-01-29 01:09:35 EST
Created attachment 89674 [details]
X config
Comment 2 Chris Ricker 2003-01-29 01:10:53 EST
Created attachment 89675 [details]
X log
Comment 3 Chris Ricker 2003-02-19 23:31:55 EST
see this on beta5 as well
Comment 4 Mike A. Harris 2003-04-12 09:45:21 EDT
This problem is probably best to be reported to XFree86.org so the driver
maintainer can investigate it.  The URL is http://bugs.xfree86.org if you'd
like to do that.  It'll increase the chances of a faster solution.

Hope this helps.
Comment 5 Chris Ricker 2003-04-23 12:22:16 EDT
Filed upstream as Bug 197, and removed beta-only bit so upstream could read this
one....
Comment 6 Mike A. Harris 2003-04-23 14:04:52 EDT
The link above is broken.  Upstream bug is:  

http://bugs.xfree86.org/cgi-bin/bugzilla/show_bug.cgi?id=197

Resolving as UPSTREAM.  Will consider backport of any upstream fixes if and
when they become available.
Comment 7 Mike A. Harris 2004-08-31 21:12:06 EDT
New upstream URL:  http://bugs.xfree86.org/show_bug.cgi?id=197

The upstream report indicates this was fixed in XFree86 CVS in late
2003.  X.Org X11 forked the XFree86 tree just prior to the 4.4.0
XFree86 release, so the X.Org sources should contain this fix as
well.

Closing as "RAWHIDE"

Note You need to log in before you can comment on or make changes to this bug.