Bug 829882 - Use polkit .rules files instead of .pkla files
Use polkit .rules files instead of .pkla files
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openstack-nova (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mark McLoughlin
Fedora Extras Quality Assurance
:
: 858311 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-07 14:16 EDT by David Zeuthen
Modified: 2012-12-20 10:24 EST (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 10:24:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Zeuthen 2012-06-07 14:16:50 EDT
With polkit version 0.106, .rules files are used instead of .pkla files, see

 http://davidz25.blogspot.com/2012/06/authorization-rules-in-polkit.html

for more information. Therefore, please port the file

 /etc/polkit-1/localauthority/50-local.d/50-nova.pkla

to use the new format. If you have any questions, I'm subscribed to this bug to help. Thanks.
Comment 1 Alan Pevec 2012-09-26 20:18:55 EDT
*** Bug 858311 has been marked as a duplicate of this bug. ***
Comment 3 Fedora Update System 2012-09-27 13:37:47 EDT
openstack-nova-2012.2-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/openstack-nova-2012.2-1.fc18
Comment 4 Fedora Update System 2012-09-27 13:40:35 EDT
openstack-nova-2012.2-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/openstack-nova-2012.2-1.fc18
Comment 5 Fedora Update System 2012-09-28 13:22:40 EDT
Package openstack-nova-2012.2-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing openstack-nova-2012.2-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15033/openstack-nova-2012.2-1.fc18
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-12-20 10:24:42 EST
openstack-nova-2012.2-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.