Bug 829883 - Use polkit .rules files instead of .pkla files
Use polkit .rules files instead of .pkla files
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: PolicyKit-olpc (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Daniel Drake
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-07 14:16 EDT by David Zeuthen
Modified: 2012-08-08 12:29 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-08 12:29:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Zeuthen 2012-06-07 14:16:51 EDT
With polkit version 0.106, .rules files are used instead of .pkla files, see

 http://davidz25.blogspot.com/2012/06/authorization-rules-in-polkit.html

for more information. Therefore, please port the file

 /var/lib/polkit-1/localauthority/10-vendor.d/olpc-overrides.pkla

to use the new format. If you have any questions, I'm subscribed to this bug to help. Thanks.
Comment 1 Daniel Drake 2012-08-08 12:29:49 EDT
Thanks for the good documentation.

Fixed in PolicyKit-olpc-1.7-1.fc18

Note You need to log in before you can comment on or make changes to this bug.