This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 829906 - XFCE: Clicking inside a window grabs and drags the window
XFCE: Clicking inside a window grabs and drags the window
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xfwm4 (Show other bugs)
17
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-07 15:15 EDT by Russell Doty
Modified: 2012-12-15 13:04 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-15 13:04:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
modified patch against xfwm-4.8.3 (2.37 KB, patch)
2012-11-19 10:07 EST, Eric Harney
no flags Details | Diff

  None (edit)
Description Russell Doty 2012-06-07 15:15:19 EDT
Description of problem:

When clicking inside an application, such as selecting a message inside Evolution, about 25% of the time the result is to grab and drag the window. The window is 3"-4" to the right of the mouse cursor and follows the mouse. The window goes outside the screen, and frequently jumps to another workspace.

Trying to position the window is problematic - it jumps around, and usually ends up in another workspace. The only workaround I've been able to find is to single click to drop the window, and then drag it normally.

Version-Release number of selected component (if applicable):

Fedora 17 with XFCE

How reproducible:
About 25% of the time; have not been able to identify any specific actions that cause it.

Steps to Reproduce:
1. Click inside a window, such as selecting a message in Evolution (also occurs with Firefox and other applications)
2.
3.
  
Actual results:

The window is grabbed and dragged.

Expected results:

The desired function selected in the application.

Additional info:
Comment 1 Kevin Fenzi 2012-06-07 17:52:37 EDT
What are your focus settings set to?

Do you have a mouse or trackpad? If trackpad are you pressing on it with multiple fingers? 
Perhaps some odd trackpad feature is coming into effect here.
Comment 2 Russell Doty 2012-06-08 11:33:23 EDT
Where do I check focus settings? I'm running default; haven't changed anything (that I know of).

This is occuring on two systems: one is a desktop with mouse only. The other is a notebook in a docking station, where it is occuring with the external mouse. I haven't used the touchpad much - fresh installation without much experience.
Comment 3 Kevin Fenzi 2012-06-08 16:21:48 EDT
Settings->window manager -> focus.
Comment 4 Russell Doty 2012-06-08 17:03:16 EDT
Ah, thank you.

Set to click to focus with a short delay. Will increase the delay and see what happens.
Comment 5 Russell Doty 2012-06-08 17:09:42 EDT
The delay is apparently for focus follows mouse. Changing it (and retaining click to focus) has no affect on the window grabbing issue.
Comment 6 Eric Harney 2012-11-15 17:10:10 EST
I also had this issue, often w/ Evolution.  I found that patching this commit into my local xfwm4 package eliminated the problem.  I've run it for a few weeks now with great results.  (F17)

http://git.xfce.org/xfce/xfwm4/commit/?id=099614e

Perhaps we can include this in the Fedora package?
Comment 7 Kevin Fenzi 2012-11-18 14:34:17 EST
Sure, but it doesn't seem to apply cleanly to 4.8. ;( 

Did you clean it up so it does? Or are you using a locally built 4.10 there?
Comment 8 Eric Harney 2012-11-19 10:07:20 EST
Created attachment 647821 [details]
modified patch against xfwm-4.8.3

Ah -- forgot about that.  I had increased the patch fuzz level in my .spec.

Here is a cleaned up version that will apply to the 4.8.3 RPM.
Comment 9 Kevin Fenzi 2012-11-24 15:14:08 EST
Can you test this scratch build: 

http://koji.fedoraproject.org/koji/taskinfo?taskID=4724268

If that looks good I can push it out as an update...
Comment 10 Eric Harney 2012-11-26 17:45:39 EST
I ran the test package all day and it seems to be working well.
Comment 11 Fedora Update System 2012-11-27 23:23:07 EST
xfwm4-4.8.3-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/xfwm4-4.8.3-3.fc17
Comment 12 Fedora Update System 2012-11-29 01:06:03 EST
Package xfwm4-4.8.3-3.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xfwm4-4.8.3-3.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-19354/xfwm4-4.8.3-3.fc17
then log in and leave karma (feedback).
Comment 13 Fedora Update System 2012-12-15 13:04:56 EST
xfwm4-4.8.3-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.