Bug 829957 - Recorded pictures and videos do not appear in area at bottom of Cheese window
Recorded pictures and videos do not appear in area at bottom of Cheese window
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: cheese (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On: 830749
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-07 17:26 EDT by Aram Agajanian
Modified: 2012-06-27 23:43 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-27 23:43:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
picture of the bottom part of the Cheese window (167.52 KB, image/png)
2012-06-21 00:07 EDT, Aram Agajanian
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 671725 None None None 2012-06-07 17:26:00 EDT

  None (edit)
Description Aram Agajanian 2012-06-07 17:26:00 EDT
Description of problem:
The default layout of the Cheese window includes an area at the bottom which is supposed to display pictures and videos that have previously been recorded with Cheese.  These pictures and videos do not appear there.

Version-Release number of selected component (if applicable):
cheese-3.4.2-2.fc17.x86_64

How reproducible:
Happens every time

Steps to Reproduce:
1.  Start Cheese
2.  Take a picture or record a video
  
Actual results:
Nothing appears in the area at the bottom of the Cheese window.

Expected results:
A small picture should appear in the area at the bottom of the Cheese window which corresponds to the picture or video recording that was just made.

Additional info:
If you switch Cheese into Wide Mode, then you can see a small picture for previously taken pictures and/or video recordings.  (In Wide Mode, these are located on the right side of the Cheese window.)  In order to switch to Wide Mode, select the Wide Mode option in the Cheese menu.
Comment 1 Hans de Goede 2012-06-10 08:37:32 EDT
After spending too much time on debugging this, I've found out that this is a recent gtk3 regression, for which I've now filed an upstream bug including all the details here:
https://bugzilla.gnome.org/show_bug.cgi?id=677809

Changing component to gtk3.
Comment 2 Hans de Goede 2012-06-10 08:41:49 EDT
Note as a workaround users can downgrade to gtk3-3.4.1 for now, or switch to widescreen mode.
Comment 3 Hans de Goede 2012-06-11 06:34:18 EDT
So upstream discussion has resulted in this needing a fix in both cheese, and in gtk3, changing this bug
back to cheese and filing a new bug for tracking the gtk3 fix.

For details see: https://bugzilla.gnome.org/show_bug.cgi?id=677809
Comment 4 Hans de Goede 2012-06-19 17:57:59 EDT
A cheese for fix is on its way, note that with many thumbnails this still won't work, and with a few thumbnails it will show only part of the thumbnails. This is a gtk3 issue which is tracked in bug 830749.
Comment 5 Fedora Update System 2012-06-19 18:01:47 EDT
cheese-3.4.2-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/cheese-3.4.2-3.fc17
Comment 6 Fedora Update System 2012-06-20 15:29:24 EDT
Package cheese-3.4.2-3.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing cheese-3.4.2-3.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-9727/cheese-3.4.2-3.fc17
then log in and leave karma (feedback).
Comment 7 Aram Agajanian 2012-06-21 00:07:05 EDT
Created attachment 593344 [details]
picture of the bottom part of the Cheese window

When using cheese-3.4.2-3.fc17.x86_64, I am seeing only the left part of the thumbnail pictures in the bottom area of the Cheese window.
Comment 8 Hans de Goede 2012-06-21 02:19:32 EDT
(In reply to comment #7)
> Created attachment 593344 [details]
> picture of the bottom part of the Cheese window
> 
> When using cheese-3.4.2-3.fc17.x86_64, I am seeing only the left part of the
> thumbnail pictures in the bottom area of the Cheese window.

Right, as mentioned in comment #4 this is "expected", as this is caused by a gtk3 bug which is not fixed yet, see bug 830749.
Comment 9 Fedora Update System 2012-06-27 23:43:51 EDT
cheese-3.4.2-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.