Bug 82996 - serial mice aren't detected
serial mice aren't detected
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: kudzu (Show other bugs)
phoebe
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks: 79579
  Show dependency treegraph
 
Reported: 2003-01-29 08:13 EST by Marius Andreiana
Modified: 2014-03-16 22:33 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-12 14:41:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kudzu output (616 bytes, text/plain)
2003-02-11 13:16 EST, Michael Schwendt
no flags Details
kudzu2 output (1.78 KB, text/plain)
2003-02-11 13:17 EST, Michael Schwendt
no flags Details
kudzu output (616 bytes, text/plain)
2003-02-12 05:06 EST, Marius Andreiana
no flags Details
kudzu2 (1.73 KB, text/plain)
2003-02-12 05:08 EST, Marius Andreiana
no flags Details

  None (edit)
Description Marius Andreiana 2003-01-29 08:13:55 EST
Seems all serial mice aren't detected ( I've tried two, somebody confirmed it on
phoebe list ).

They work if manually configured with mouseconfig.

Related bugs:
bug #865147, #47757
Comment 1 Michael Schwendt 2003-01-29 10:29:20 EST
Confirmed. Fails for me with both Phoebe 8.0.92 and 8.0.93. Copying from bug #80332:

  Probing for mouse: No - mouse

Suffice to say, mouse detection worked flawlessly with older versions of Red Hat
Linux, including the Limbo and (null) betas. My mouse is a classic 3-button
serial mouse from Logitech on /dev/ttyS1. Kernel info from Valhalla:

02f8-02ff : serial(auto)
03f8-03ff : serial(auto)

Serial driver version 5.05c (2001-07-08) with MANY_PORTS MULTIPORT SHARE_IRQ
SERIAL_PCI ISAPNP enabled
ttyS0 at 0x03f8 (irq = 4) is a 16550A
ttyS1 at 0x02f8 (irq = 3) is a 16550A
Comment 2 Bill Nottingham 2003-02-11 10:47:41 EST
Please download http://people.redhat.com/notting/kudzu/kudzu,
and run (as root, with gpm disabled, on the console)

kudzu -p -b serial

Thanks.
Comment 3 Bill Nottingham 2003-02-11 12:32:58 EST
Also, try kudzu2 in the same location.
Comment 4 Michael Schwendt 2003-02-11 13:16:04 EST
Created attachment 90005 [details]
kudzu output

kudzu ran on Phoebe 8.0.93
Comment 5 Michael Schwendt 2003-02-11 13:17:19 EST
Created attachment 90006 [details]
kudzu2 output

kudzu2 ran on Valhalla via a chroot'ed Phoebe 8.0.93
Comment 6 Marius Andreiana 2003-02-12 05:06:30 EST
Created attachment 90028 [details]
kudzu output
Comment 7 Marius Andreiana 2003-02-12 05:08:25 EST
Created attachment 90029 [details]
kudzu2
Comment 8 Marius Andreiana 2003-02-12 05:10:36 EST
See above outputs on clean install of phoebe2
Comment 9 Bill Nottingham 2003-02-12 14:41:45 EST
Fixed in 0.99.94-1.

Note You need to log in before you can comment on or make changes to this bug.