Bug 82997 - mouse cursor is a big rectangle on sis video card
mouse cursor is a big rectangle on sis video card
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks: 82789
  Show dependency treegraph
 
Reported: 2003-01-29 08:16 EST by Marius Andreiana
Modified: 2007-04-18 12:50 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-19 17:39:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output from my system (3.46 KB, application/octet-stream)
2003-02-11 02:18 EST, Felipe Alfaro Solana
no flags Details
XFree86 Server Log (7.18 KB, application/octet-stream)
2003-02-11 02:20 EST, Felipe Alfaro Solana
no flags Details
XF86Config configuration file (1.33 KB, application/octet-stream)
2003-02-11 02:21 EST, Felipe Alfaro Solana
no flags Details

  None (edit)
Description Marius Andreiana 2003-01-29 08:16:55 EST
on sis 5591/5592 agp video card, mouse cursor is displayed as a big (30x30
pixels ) rectagle filled with random stuff. There's also a dotted line
(sometimes two) almost in the middle of the screen.

Please let me know if other information is needed or how could I help fixing this.

Thank you!
Comment 1 Marius Andreiana 2003-01-29 09:57:55 EST
I'll try adding Option "SWCursor" in Display section.
Comment 2 Felipe Alfaro Solana 2003-02-02 14:16:27 EST
*** Bug 83284 has been marked as a duplicate of this bug. ***
Comment 3 Felipe Alfaro Solana 2003-02-02 14:24:59 EST
I'm also experiencing this on my Packard Bell Chrom@ laptop (ATI Rage Mobility 
M1 AGP 8MB with SourceForge's Gatos ATI.2 XFree86 4.3.0 video driver) when 
using XFree86-4.2.99-4.20030129. I have had to revert to the Phoebe version of 
XFree86 package.

Curiously, I have another Compaq Presario laptop running Phoebe2 with "up2date" 
upgraded packages (XFree86-4.2.99-3.20030115, if my memory serves me well). If 
I run a graphical application remotely on that laptop, but instruct it to use 
my laptop X server (running the original Phoebe2 XFree), by logging to the 
Compaq laptop by using SSH and X11 forwarding, the mouse cursor glitches can be 
reproduced.

Could it be a X11 protocol problem? Why applications ran under original XFree 
do not exhibit this behavior, but applications ran under the upgraded XFree do?
Comment 4 Mike A. Harris 2003-02-03 00:39:15 EST
Bug 82997 is not a duplicate of this one.

Bug 82997 is broken hardware mouse cursor code on SiS chipsets, likely
fixed by using:  Option "swcursor" in the Device section of the config
file (please test this on SiS).

Note that the Radeon problem will also go away with swcursor, but that
these two issues while both related to hardware mouse cursor, are unrelated
and driver specific.  The radeon problem can also be worked around by
changing the default mouse theme to "core" in:

       /usr/share/icons/default/index.theme
Comment 5 Mike A. Harris 2003-02-03 00:41:58 EST
Err, I mean Bug 83284 is not a duplicate


Comment 6 Thomas J. Baker 2003-02-03 14:38:44 EST
I have this problem on my laptop with the ATI Rage Mobilty chipset and on a
desktop with a an ATI Mach64 so there's apparently a problem with the "ati"
driver too.
Comment 7 Marius Andreiana 2003-02-05 06:44:04 EST
Option "SWCursor" in Display section fixes this for Sis video card.
Comment 8 Mike Chambers 2003-02-10 22:45:56 EST
Please attache your xfree config file, log file and dmesg so this bug can 
possibly be tracked a little further.
Comment 9 Mike Chambers 2003-02-10 22:46:46 EST
Check last comments in regards to attaching files to troubleshoot better.
Comment 10 Felipe Alfaro Solana 2003-02-11 02:18:56 EST
Created attachment 89984 [details]
dmesg output from my system

This is the output of the "dmesg" command on my laptop.
Comment 11 Felipe Alfaro Solana 2003-02-11 02:20:01 EST
Created attachment 89985 [details]
XFree86 Server Log

This is the XFree86 Server Log of my system
Comment 12 Felipe Alfaro Solana 2003-02-11 02:21:00 EST
Created attachment 89986 [details]
XF86Config configuration file

This is the configuration file I'm using... It was generated when installing
Phoebe2 and it hasn't been modified since then.
Comment 13 Felipe Alfaro Solana 2003-02-11 02:25:08 EST
Oops!!!! I did it again ;-)

Attachments 89984, 89985 and 89986 are for the mouse hardware cursor problems
I'm experiencing with the ATI RAGE Mobility M1 AGP 8MB video card on my Packard
Bell Chroma@ laptop and are *NOT* related the SIS video driver.

I think I shouldn't have sent them here. Should I remove them?

Thanks for your patience...
Comment 14 Mike Chambers 2003-02-11 06:23:10 EST
Felipe,

Yes you should delete those and post them to the other bug related to your 
hardware.  Also, they should be just a plain text file, not compressed or 
anything.  Easier it open and read, thanks.
Comment 15 Mike A. Harris 2003-04-11 06:39:31 EDT
Marius, please attach your X server log, or the output of "lspci -vvn",
so I can properly detect the correct SiS card by PCI ID.

Felipe - your Mach64 problem is totally unrelated to this SiS bug report,
and should be filed in a separate bug report if it isn't already.

Thanks.
Comment 16 Marius Andreiana 2003-05-19 16:27:40 EDT
Mike,

I don't have access to that system anymore. I won't be able to provide the info.
Ok to close this and perhaps you'll get more feedback on next beta, if it will
still be an issue?
Comment 17 Mike A. Harris 2003-05-19 17:39:40 EDT
Ok, closing RAWHIDE for now.  Reopen with details, and above info it the
problem recurs.

TIA

Note You need to log in before you can comment on or make changes to this bug.