Bug 829989 - QE Feedback - Getting Started Guide - Chapter 7
QE Feedback - Getting Started Guide - Chapter 7
Status: CLOSED CURRENTRELEASE
Product: JBoss Data Grid 6
Classification: JBoss
Component: Documentation (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Misha H. Ali
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-07 19:07 EDT by Misha H. Ali
Modified: 2012-08-15 10:44 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-14 23:06:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Misha H. Ali 2012-06-07 19:07:45 EDT
Chapter 7
---------

* http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/Getting_Started_Guide/chap-Run_JBoss_Data_Grid_as_an_Embedded_Data_Grid.html

Where do I get the clustered quickstart zip at Infinispan's download page? I cannot find it. Shouldn't we rather mention the github repository?
(https://github.com/infinispan/infinispan-quickstart)

I was against naming specific java files in chapter 6. That's because I did not know from the docu where they come from. However, if 
we mention the infinispan-quickstarts in the chapter 6 (at the beginning) in a proper way, we can leave the file names there.

* http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/Getting_Started_Guide/sect-Run_JBoss_Data_Grid_in_a_Cluster.html

This topic is very confusing because in the following topics you are describing JBoss Data Grid in library mode with **Java SE** and running
standalone.sh here does not make sense at all because there is not server. There's just a simple Java SE application running as standalone.
Furthermore

So this topic needs to be completely rewritten or removed:) 

* http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/Getting_Started_Guide/Customize_the_Default_Cluster_Configuration.html
(related to Tomas' comment no. 4)

I would add that example configuration file for jgroups can be found in Infinispan distribution (jgroups-udp.xml or jgroups-tcp.xml) 
When users want to use a specific jgroups configuration, they need to put the configuration file on the classpath of the application.

Moreover, the XML configuration snippet mentioned by Tomas is about to be placed in infinispan.xml file and the application loads the
file in the same way as in http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/Getting_Started_Guide/Load_the_Configuration_File.html
Comment 1 Misha H. Ali 2012-06-08 00:51:52 EDT
1. Created a small topic listing both locations and added to the beginnings of chapters 6 and 7. Links when the next brew occurs.

2. Topic removed according to QE recommendation from chapter. Originally, it was section 7.3.1. Link to show it is no longer visible after brew.

3. Tomas' raised bugs are addressed in another bug, hence this is left out in this bug.
Comment 2 Misha H. Ali 2012-06-08 04:21:33 EDT
(In reply to comment #1)
> 1. Created a small topic listing both locations and added to the beginnings
> of chapters 6 and 7. Links when the next brew occurs.

* http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/Getting_Started_Guide/chap-Run_JBoss_Data_Grid_as_an_Embedded_Cache.html

* http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/Getting_Started_Guide/chap-Run_JBoss_Data_Grid_as_an_Embedded_Data_Grid.html

> 
> 2. Topic removed according to QE recommendation from chapter. Originally, it
> was section 7.3.1. Link to show it is no longer visible after brew.
> 

* http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/Getting_Started_Guide/chap-Run_JBoss_Data_Grid_as_an_Embedded_Data_Grid.html

Section 7.3.1. no longer exists.

> 3. Tomas' raised bugs are addressed in another bug, hence this is left out
> in this bug.
Comment 3 Martin Gencur 2012-06-08 06:14:42 EDT
The fixes loog very good, even the new topics are nice. The only issue I still see is at http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/Getting_Started_Guide/Customize_the_Default_Cluster_Configuration.html ...I see the link to $JDG_Quickstart/clustered-cache/src/main/resources/jgroups.xml -> it is not a JDG quickstart but rather community Infinispan quickstart so I would change it to something like infinispan-quickstart/clustered-cache/src/main/resources/jgroups.xml
Comment 4 Misha H. Ali 2012-06-08 08:09:40 EDT
The path now fixed and available at the same link (refresh in case old version is cached).

Note You need to log in before you can comment on or make changes to this bug.