Bug 830046 - Mouse's battery taken as computer's battery
Mouse's battery taken as computer's battery
Status: CLOSED DUPLICATE of bug 816775
Product: Fedora
Classification: Fedora
Component: upower (Show other bugs)
17
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-08 00:52 EDT by Mikel P.
Modified: 2013-02-20 15:22 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-20 15:22:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikel P. 2012-06-08 00:52:30 EDT
Description of problem:
Fedora thinks my Magic Mouse's batteries are my computer's (an iMac)
When my mouse batteries are low, it shows a message that the computer's batteries are low and that it's about to hibernate (and it does.)

How reproducible:


Steps to Reproduce:
1. Connect Magic Mouse with low batteries 
2. Watch GNOME show an alert about low batteries.
3. Watch the computer hibernate.
  
Actual results:
Computer hibernates.

Expected results:
Computer shows the battery level for the mouse as the mouse's battery level (not the computer's) and does not hibernate when the mouse battery is low, instead showing an alert that the mouse might turn off at any moment soon.

Additional info:
The iMac has no internal battery as it is a desktop computer. I guess this applies to other PCs too and not just the iMac, but I could be wrong.
Comment 1 Mikel P. 2012-06-08 03:43:34 EDT
It seems the problem went away. I updated some packages (among them was the kernel) but I didn't pay attention to it after I rebooted into the new kernel.

Guessing it was fixed in kernel 3.4.0, I'd say it's fixed...
Comment 2 Ilkka Tengvall 2012-10-22 05:47:41 EDT
no it's not:

I get the very same on fedora 17 on my PC. I believe it's caused by incorrect polling of the apple bt keyboard and bt touchpad (tragic mackpad) mouse. It's trashing the logs with this:

[349847.631435] power_supply hid-7C:C3:A1:XX:XX:XX-battery: driver failed to report `capacity' property: -5
[349877.481202] power_supply hid-7C:C3:A1:XX:XX:XX-battery: driver failed to report `capacity' property: -5
[349907.431923] power_supply hid-7C:C3:A1:XX:XX:XX-battery: driver failed to report `capacity' property: -5



upower-0.9.17-1.fc17.x86_64
kernel-3.6.2-4.fc17.x86_64
Comment 3 Ilkka Tengvall 2012-10-22 06:04:26 EDT
It seems there are several tickets open related to the same issue. At least:

812625, 830046, 845770, 806295, 863524
Comment 4 Daniel Nicoletti 2012-10-22 08:41:24 EDT
No kernel 3.4 can actually fix his problem, at that version was added an option to tell the battery is now a power supply.
@Ilkka your problem is not correctly getting the battery status.
This bug should be closed.
Comment 5 Christopher Beland 2013-02-20 15:22:50 EST

*** This bug has been marked as a duplicate of bug 816775 ***

Note You need to log in before you can comment on or make changes to this bug.