Bug 83007 - High ascii characters in man pages
High ascii characters in man pages
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: man-pages (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
Ben Levenson
na
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-29 09:59 EST by Tom Laudeman
Modified: 2007-04-18 12:50 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-20 16:27:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Laudeman 2003-01-29 09:59:31 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
Many of the man pages have high ascii characters. man CGI and try to search for
-  (hyphen). Doesn't work. Fire up emacs, meta-X, manual-entry, CGI. Try to
search for - (a hyphen). Doesn't work. Put the cursor on what appears to be a
hyphen. Meta-x =  

The mini-buffer shows (among other things) the hex code for the current
character. It will be something above 127 decimal. 

The man pages also contain some weird high ascii instead of ' (single quote).

The same problem occurs with man ls



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.emacs
2. man ls or man CGI
3. select what appears to be a - (hyphen) and check the hex code
    

Actual Results:  The hex code is about 127 decimal.

Expected Results:  The hex code should have been 127 decimal or less. Only
characters we can type at the keyboard from emacs or the bash shell should be in
man pages.

Additional info:
Comment 1 David Dombek 2003-02-12 14:09:20 EST
check /etc/sysconfig/i18n

The values for most of the US should be:
LANG="en_US"
SUPPORTED="en_US:en"
SYSFONT="lat0-sun16"
SYSFONTACM="iso01"

Once you save, open another window to the box by logging in again and do a man 
ls.  The problem should be solved.
Comment 2 Tom Laudeman 2003-02-12 14:39:36 EST
Setting environment variables to control the internationalization of the man
pages is great. I tried your recommended settings and they work great. 

However, this means that the RH installer missed a setting since it knows my
timezone/language/country, and apparently missed these moderately important
settings. 

My /etc/sysconfig/i18n reads:

LANG="en_US.UTF-8"
SUPPORTED="en_US.UTF-8:en_US:en"
SYSFONT="latarcyrheb-sun16"

Thanks!
p.s. Is it possible to leave a comment line in i18n with a URL for
documentation? Example lines would be cool. The Linux world needs more examples.
Comment 3 David Dombek 2003-02-12 14:51:38 EST
Yes you can leave comments in the file.

FYI, I was having the same problem at the same time you were.  I was searching 
the bugs for an answer but didn't find one.  Turns out it was a quick find for 
the answer so I thought I would post.

I don't work for RedHat. :-)

I agree the installation has some sort of bug.
Comment 4 Eido Inoue 2003-02-20 16:27:08 EST
the man/groff combo in rawhide has fixed this problem. dashes are now plain old
ascii dash/minus chars.

Note You need to log in before you can comment on or make changes to this bug.