Bug 83013 - satellite-sync won't get AS packages (reports them as extinct), unless satellite org has AS entitlement
Summary: satellite-sync won't get AS packages (reports them as extinct), unless satell...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mihai Ibanescu
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
: 83947 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-29 15:40 UTC by Jason Kohles
Modified: 2007-07-31 19:15 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-04-16 16:00:32 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jason Kohles 2003-01-29 15:40:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
Sometime around the end of december/beginning of january, my satellite stopped
downloading AS errata.  This was finally resolved when an AS entitlement was
added to RHN for the org that owned the satellite, so apparently unless you have
at least one AS entitlment for the satellite to hit against, you can't get
packages (all the packages that should be downloaded are reported as extinct).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.satellite-sync -c redhat-advanced-server-i386

    

Actual Results:  Wed Jan 29 10:03:35 2003 -    RPM fetch summary (RPMs for
missing metadata): redhat-advanced-server-i386
                                  success: 0
                                  matched: 0
                                  failed:  0
                                  extinct: 406


Expected Results:  Wed Jan 29 10:28:08 2003 -    RPM fetch summary (RPMs for
missing metadata): redhat-advanced-server-i386
                                  success: 406
                                  matched: 0
                                  failed:  0
                                  extinct: 0


Additional info:

[root@linuxsat-m01 root]# rpm -qa | grep rhns
rhns-ssl-cert-1.0-1
rhns-1.2.6.1-13
rhns-app-1.2.6.1-13
rhns-certs-tools-1.3.0-4
rhns-schema-tools-1.3.0-2
rhns-server-1.2.6.1-13
rhns-xmlrpc-1.2.6.1-13
rhns-satellite-tools-1.2.6.1-13
rhns-xp-1.2.6.1-13

Comment 1 Mihai Ibanescu 2003-01-31 17:42:56 UTC
Will have to figure out a better way to message missing rpms vs. rpms one does
not have access to.

Comment 2 Jason Kohles 2003-01-31 18:00:12 UTC
The bigger issue is that I SHOULD have had access to them, the satellite has
8,000 AS entitlments, but to make it work we had to add one to the org on RHN as
well.

Comment 3 Mihai Ibanescu 2003-02-18 21:28:59 UTC
Bug 83947 should fix this. Code to be pushed Feb 24.

Comment 4 Josef Komenda 2003-02-20 16:17:32 UTC
*** Bug 83947 has been marked as a duplicate of this bug. ***

Comment 5 Mihai Ibanescu 2003-04-16 16:00:32 UTC
Closing


Note You need to log in before you can comment on or make changes to this bug.