Bug 830145 - [abrt] yum-3.4.3-25.fc17: misc.py:754:_decompress_chunked:IOError: [Errno 13] Permission denied: '/var/cache/yum/x86_64/17/rpmfusion-free/f70c79ecf90f10224ce6ebd6fa94adeb7d3a02d874369c2f5c5863bff39ced81-comps.xml'
[abrt] yum-3.4.3-25.fc17: misc.py:754:_decompress_chunked:IOError: [Errno 13]...
Status: CLOSED DUPLICATE of bug 829505
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
abrt_hash:cc59c72cc0a460f8e8a30d88034...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-08 07:15 EDT by Mohammad Razeghi
Modified: 2014-01-21 18:22 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-08 08:53:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: smolt_data (4.92 KB, text/plain)
2012-06-08 07:15 EDT, Mohammad Razeghi
no flags Details

  None (edit)
Description Mohammad Razeghi 2012-06-08 07:15:25 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
cmdline:        /usr/bin/python -t /usr/share/yum-cli/completion-helper.py -d 0 -C list available ''
executable:     /usr/share/yum-cli/completion-helper.py
kernel:         3.3.7-1.fc17.x86_64
time:           Fri 01 Jun 2012 02:26:17 PM IRDT
uid:            1000
username:       mohammad

smolt_data:     Text file, 5037 bytes

backtrace:
:misc.py:754:_decompress_chunked:IOError: [Errno 13] Permission denied: '/var/cache/yum/x86_64/17/rpmfusion-free/f70c79ecf90f10224ce6ebd6fa94adeb7d3a02d874369c2f5c5863bff39ced81-comps.xml'
:
:Traceback (most recent call last):
:  File "/usr/share/yum-cli/completion-helper.py", line 89, in <module>
:    main(sys.argv[1:])
:  File "/usr/share/yum-cli/completion-helper.py", line 83, in main
:    base.doCommands()
:  File "/usr/share/yum-cli/cli.py", line 485, in doCommands
:    return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd, self.extcmds)
:  File "/usr/share/yum-cli/completion-helper.py", line 45, in doCommand
:    patterns=[get_pattern(extcmds)])
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 2660, in doPackageLists
:    avail = self.pkgSack.returnNewestByNameArch(patterns=patterns,
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 1003, in <lambda>
:    pkgSack = property(fget=lambda self: self._getSacks(),
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 767, in _getSacks
:    self.repos.populateSack(which=repos)
:  File "/usr/lib/python2.7/site-packages/yum/repos.py", line 265, in populateSack
:    self.doSetup()
:  File "/usr/lib/python2.7/site-packages/yum/repos.py", line 92, in doSetup
:    self.ayum.plugins.run('postreposetup')
:  File "/usr/lib/python2.7/site-packages/yum/plugins.py", line 187, in run
:    func(conduitcls(self, self.base, conf, **kwargs))
:  File "/usr/lib/yum-plugins/langpacks.py", line 78, in postreposetup_hook
:    infile = yum.misc.decompress(infile, check_timestamps=True)
:  File "/usr/lib/python2.7/site-packages/yum/misc.py", line 1132, in decompress
:    _decompress_chunked(filename, out, ztype)
:  File "/usr/lib/python2.7/site-packages/yum/misc.py", line 754, in _decompress_chunked
:    destination = open(dest, 'w')
:IOError: [Errno 13] Permission denied: '/var/cache/yum/x86_64/17/rpmfusion-free/f70c79ecf90f10224ce6ebd6fa94adeb7d3a02d874369c2f5c5863bff39ced81-comps.xml'
:
:Local variables in innermost frame:
:dest: '/var/cache/yum/x86_64/17/rpmfusion-free/f70c79ecf90f10224ce6ebd6fa94adeb7d3a02d874369c2f5c5863bff39ced81-comps.xml'
:source: '/var/cache/yum/x86_64/17/rpmfusion-free/f70c79ecf90f10224ce6ebd6fa94adeb7d3a02d874369c2f5c5863bff39ced81-comps.xml.gz'
:s_fn: <gzip open file '/var/cache/yum/x86_64/17/rpmfusion-free/f70c79ecf90f10224ce6ebd6fa94adeb7d3a02d874369c2f5c5863bff39ced81-comps.xml.gz', mode 'rb' at 0x1a80db0 0x1b9ef10>
:ztype: 'gz'
Comment 1 Mohammad Razeghi 2012-06-08 07:15:30 EDT
Created attachment 590406 [details]
File: smolt_data
Comment 2 Zdeněk Pavlas 2012-06-08 08:53:15 EDT

*** This bug has been marked as a duplicate of bug 829505 ***

Note You need to log in before you can comment on or make changes to this bug.