Bug 830163 - manually chosen encoding not saved when changing tabs
manually chosen encoding not saved when changing tabs
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: thunderbird (Show other bugs)
17
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-08 08:36 EDT by Maximilian Reininghaus
Modified: 2012-06-19 09:00 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-19 09:00:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 487386 None None None 2012-06-19 09:00:51 EDT

  None (edit)
Description Maximilian Reininghaus 2012-06-08 08:36:00 EDT
Description of problem:
If a mail is viewed in a tab with the encoding manually chosen in the menu it is reset to default after changing to another tab and back.


Version-Release number of selected component (if applicable):
12.0.1 (x86_64)

How reproducible:
always


Steps to Reproduce:
1. open a mail in new tab
2. change encoding to something different than the default.
3. go to another tab and back.
  
Actual results:
The encoding is reset to what it was before the manual change.


Expected results:
The encoding should not change to default again but hold the value from before viewing another tab.

Additional info: none
Comment 1 Jan Horak 2012-06-19 09:00:51 EDT
This seems to be upstream bug:
https://bugzilla.mozilla.org/show_bug.cgi?id=487386
Tabs don't remember internal states and are reloaded each time you switch to them. Fix seems to be non-trivial (see bug at mozilla bugzilla). Closing as upstream, we're going to track this issue there.

Note You need to log in before you can comment on or make changes to this bug.