Bug 830218 - Index xlator should be loaded on Upgrade of rpms
Index xlator should be loaded on Upgrade of rpms
Status: CLOSED CURRENTRELEASE
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
2.0
Unspecified Unspecified
medium Severity high
: ---
: ---
Assigned To: Bug Updates Notification Mailing List
amainkar
:
Depends On: 825872
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-08 10:55 EDT by Amar Tumballi
Modified: 2015-03-18 00:38 EDT (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0qa5-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 825872
Environment:
Last Closed: 2015-03-18 00:38:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Amar Tumballi 2012-06-08 10:55:31 EDT
+++ This bug was initially created as a clone of Bug #825872 +++

Description of problem:
Index xlator should be loaded on bricks after Upgrade of rpms

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

--- Additional comment from pkarampu@redhat.com on 2012-06-05 06:57:36 EDT ---

Index xlator is introduced in 3.3. Old volfiles will not have this xlator loaded. On rpm upgrade (rpm -Uvh) glusterd will re-generate the volfiles to load this extra xlator. Please verify that the brick volfiles have the index xlator loaded after the upgrade.


----------------------
More comment during the verifying is in bug 824231 (comment #3) https://bugzilla.redhat.com/show_bug.cgi?id=824231#c3
Comment 2 Vijay Bellur 2012-07-04 03:18:49 EDT
CHANGE: http://review.gluster.com/3548 (glusterd: copy /etc/glusterd to /var/lib and remove /etc/glusterd instead of           moving) merged in master by Anand Avati (avati@redhat.com)
Comment 3 Amar Tumballi 2012-07-04 05:14:38 EDT
fixed upstream.
Comment 4 Vijaykumar Koppad 2013-01-10 01:24:55 EST
If you Try to upgrade glusterfs from 3.2.6 to 3.3 or 3.4 , it gives something like this ,

Preparing...                ########################################### [100%]
   1:glusterfs              ########################################### [ 14%]
   2:glusterfs-fuse         ########################################### [ 29%]
   3:glusterfs-server       ########################################### [ 43%]
mv: cannot move `/etc/glusterd' to `/var/lib/glusterd': Directory not empty
glusterd: symbol lookup error: glusterd: undefined symbol: glusterfs_ctx_new
glusterd: symbol lookup error: glusterd: undefined symbol: glusterfs_ctx_new
warning: %post(glusterfs-server-3.4.0qa5-1.el6rhs.x86_64) scriptlet failed, exit status 127
   4:glusterfs-devel        ########################################### [ 57%]
   5:glusterfs-geo-replicati########################################### [ 71%]
warning: %post(glusterfs-geo-replication-3.4.0qa5-1.el6rhs.x86_64) scriptlet failed, exit status 1
   6:glusterfs-rdma         ########################################### [ 86%]
   7:glusterfs-debuginfo    ########################################### [100%],


Since i am using brewbuild rpms, there might be possibility that glusterfs.spec.in is not updated as given in the patch in the brewbuild. And also the patch given here doesn't contain anything related to Index translator.

Note You need to log in before you can comment on or make changes to this bug.