Bug 830220 - graphics generated using gd contain errors
graphics generated using gd contain errors
Status: CLOSED DUPLICATE of bug 790400
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gd (Show other bugs)
6.5
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Honza Horak
BaseOS QE - Apps
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-08 10:56 EDT by eaforesman
Modified: 2012-06-11 04:22 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 798255
Environment:
Last Closed: 2012-06-11 04:22:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description eaforesman 2012-06-08 10:56:12 EDT
+++ This bug was initially created as a clone of Bug #798255 +++

+++ This bug was initially created as a clone of Bug #790400 +++

Created attachment 561900 [details]
gnuplot commands to reproduce

Description of problem:
  graphics generated using libgd contain errors

Version-Release number of selected component (if applicable):
  gd-2.0.35-10.el6.x86_64

How reproducible:
  always

Steps to Reproduce:
1. run 'gnuplot reproducer.gnuplot'
2. inspect generated 'reproducer.jpeg'

Actual results:
  reproducer.jpeg contains a block/error in the middle

Expected results:
  reproducer.jpeg should not contain a block/error in the middle

Additional info:
- removing the last 14 lines from gd-2.0.35-AALineThick.patch makes the problem disappear

--- Additional comment from chorn@redhat.com on 2012-02-14 07:45:52 EST ---

Created attachment 561901 [details]
example output from reproducer

--- Additional comment from hhorak@redhat.com on 2012-02-14 09:35:32 EST ---

Can you also attach dat..dat3 files, please?
$ gnuplot reproducer.gnuplot 
"reproducer.gnuplot", line 15: warning: Skipping unreadable file "dat"
"reproducer.gnuplot", line 15: warning: Skipping unreadable file "dat"
"reproducer.gnuplot", line 15: warning: Skipping unreadable file "dat"
"reproducer.gnuplot", line 15: warning: Skipping unreadable file "dat2"
"reproducer.gnuplot", line 15: warning: Skipping unreadable file "dat4"
"reproducer.gnuplot", line 15: warning: Skipping unreadable file "dat3"
"reproducer.gnuplot", line 15: No data in plot

--- Additional comment from chorn@redhat.com on 2012-02-14 09:39:15 EST ---

Created attachment 561916 [details]
reproducer datafile

--- Additional comment from chorn@redhat.com on 2012-02-14 09:40:00 EST ---

Created attachment 561917 [details]
reproducer datafile

--- Additional comment from chorn@redhat.com on 2012-02-14 09:40:23 EST ---

Created attachment 561918 [details]
reproducer datafile

--- Additional comment from chorn@redhat.com on 2012-02-14 09:40:47 EST ---

Created attachment 561919 [details]
reproducer datafile

--- Additional comment from hhorak@redhat.com on 2012-02-28 07:46:20 EST ---

Created attachment 566299 [details]
little reproducer

There is a problem when we draw gdAntiAliased line, which has a negative 'dy', i.e. coordinates y1 > y2. It can be reproduced with a reproducer attached:
$ gcc -o reproducer790400 reproducer790400.c -lgd
$ ./reproducer790400 >reproducer790400.png

Actual results:
reproducer790400.png contains a black box

Expected results:
reproducer790400.png contains almost vertical line

--- Additional comment from hhorak@redhat.com on 2012-02-28 07:49:00 EST ---

Created attachment 566300 [details]
fixed patch gd-2.0.35-AALineThick.patch

It is a bug in our patch, so the attached file is a fixed version of already applied gd-2.0.35-AALineThick.patch.

--- Additional comment from updates@fedoraproject.org on 2012-02-28 08:21:56 EST ---

gd-2.0.35-16.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/gd-2.0.35-16.fc17

--- Additional comment from updates@fedoraproject.org on 2012-02-28 08:26:28 EST ---

gd-2.0.35-14.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/gd-2.0.35-14.fc16

--- Additional comment from updates@fedoraproject.org on 2012-02-28 08:33:05 EST ---

gd-2.0.35-14.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/gd-2.0.35-14.fc15

--- Additional comment from updates@fedoraproject.org on 2012-02-28 15:41:40 EST ---

Package gd-2.0.35-16.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gd-2.0.35-16.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-2630/gd-2.0.35-16.fc17
then log in and leave karma (feedback).

--- Additional comment from updates@fedoraproject.org on 2012-03-08 01:03:07 EST ---

gd-2.0.35-16.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

--- Additional comment from updates@fedoraproject.org on 2012-03-20 22:36:00 EDT ---

gd-2.0.35-14.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

--- Additional comment from updates@fedoraproject.org on 2012-03-20 22:40:57 EDT ---

gd-2.0.35-14.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 2 Honza Horak 2012-06-11 04:22:38 EDT

*** This bug has been marked as a duplicate of bug 790400 ***

Note You need to log in before you can comment on or make changes to this bug.