Bug 830234 - Package config does not include a reference to the /usr/include/x86_64-linux
Package config does not include a reference to the /usr/include/x86_64-linux
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: ruby (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeroen van Meeuwen
Fedora Extras Quality Assurance
:
: 830235 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-08 11:24 EDT by Darryl L. Pierce
Modified: 2015-06-21 20:07 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-29 16:58:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Darryl L. Pierce 2012-06-08 11:24:16 EDT
Description of problem:

There needs to be a reference in the package config file to the architecture-specific directory; i.e., /usr/include/x86_64-linux on 64bit systsems.

When trying to build using cmake, for example, the discovery portion only finds the reference to /usr/include. However, there are header files in /usr/include/x86_64-linux that are necessary but which are not being pointed to by the config file.


Version-Release number of selected component (if applicable):

mcpierce@mcpierce-laptop:~  $ rpm -q ruby-devel
ruby-devel-1.9.3.194-10.1.fc17.x86_64


How reproducible:

100%


Steps to Reproduce:
1. Create a cmake project that depends on Ruby.
2. Use the cmake command to generate Makefiles.
3. Use make to build.
  
Actual results:

The following results, which are due to pkgconfig not telling cmake about the platform-specific header location:

Scanning dependencies of target cqpid_ruby
[ 93%] Building CXX object bindings/qpid/ruby/CMakeFiles/cqpid_ruby.dir/rubyRUBY_wrap.o
In file included from /usr/include/ruby.h:32:0,
                 from /home/mcpierce/Programming/Qpid/cmake/bindings/qpid/ruby/rubyRUBY_wrap.cxx:856:
/usr/include/ruby/ruby.h:24:25: fatal error: ruby/config.h: No such file or directory
compilation terminated.
make[2]: *** [bindings/qpid/ruby/CMakeFiles/cqpid_ruby.dir/rubyRUBY_wrap.o] Error 1
make[1]: *** [bindings/qpid/ruby/CMakeFiles/cqpid_ruby.dir/all] Error 2
make: *** [all] Error 2


Expected results:

Compilation to complete successfully.

Additional info:
Comment 1 Darryl L. Pierce 2012-06-08 11:26:24 EDT
*** Bug 830235 has been marked as a duplicate of this bug. ***
Comment 2 Vít Ondruch 2012-06-29 09:46:43 EDT
Hi Daryl,

Would you mind to open upstream bug regarding this issue? It shouldn't be a big deal, since it should be just a simple extension of [1]

Vit



[1] https://github.com/ruby/ruby/blob/trunk/template/ruby.pc.in
Comment 3 Darryl L. Pierce 2012-06-29 16:58:44 EDT
Turns out the problem was not with Ruby's pkgconfig settings but in our CMakeList.txt file. We had a type (RUBY_INCLUDE_DIR instead of RUBY_INCLUDE_DIRS) and weren't using the include_directories($RUBY_INCLUDE_DIRS) directive but instead were explicitly writing the commandline out.

Note You need to log in before you can comment on or make changes to this bug.