Bug 830241 - Search widget drop down elements design issue.
Search widget drop down elements design issue.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.0
Unspecified Unspecified
low Severity medium (vote)
: Unspecified
: 6.0
Assigned To: Mike McCune
Hayk Hovsepyan
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-08 11:42 EDT by Hayk Hovsepyan
Modified: 2014-09-18 12:47 EDT (History)
3 users (show)

See Also:
Fixed In Version: katello-1.3.0-1.git.94.15d1b9d.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-02 10:07:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Dropdown screenshot. (316.14 KB, image/png)
2012-06-08 11:42 EDT, Hayk Hovsepyan
no flags Details

  None (edit)
Description Hayk Hovsepyan 2012-06-08 11:42:59 EDT
Created attachment 590463 [details]
Dropdown screenshot.

Description of problem:
When clicking on drop down arrow of search widget, it opens search history elements with hidden left part.
This happens when search widget is closed to left border of the page.
This happens in many pages where search widget exists (Custom Content Providers, Package Filters etc.)


Version-Release number of selected component (if applicable):
qpid-cpp-server-ssl-0.14-14.el6_2.x86_64
pulp-selinux-server-1.0.4-1.el6.noarch
katello-selinux-0.1.10-1.el6.noarch
katello-all-0.1.313-1.el6_3.noarch
katello-cli-common-0.1.108-1.el6_3.noarch
qpid-cpp-client-ssl-0.14-14.el6_2.x86_64
katello-glue-foreman-0.1.313-1.el6_3.noarch
katello-configure-0.1.109-1.el6_3.noarch
katello-qpid-client-key-pair-1.0-1.noarch
m2crypto-0.21.1.pulp-7.el6.x86_64
python-qpid-0.14-7.el6_2.noarch
python-isodate-0.4.4-4.pulp.el6.noarch
katello-cli-0.1.108-1.el6_3.noarch
pulp-common-1.0.4-1.el6.noarch
qpid-cpp-server-0.14-14.el6_2.x86_64
candlepin-tomcat6-0.6.5-1.el6_2.noarch
katello-glue-candlepin-0.1.313-1.el6_3.noarch
katello-0.1.313-1.el6_3.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
python-oauth2-1.5.170-2.pulp.el6.noarch
katello-certs-tools-1.0.7-1.el6_3.noarch
candlepin-0.6.5-1.el6_2.noarch
qpid-cpp-client-0.14-14.el6_2.x86_64
pulp-1.0.4-1.el6.noarch
katello-common-0.1.313-1.el6_3.noarch
katello-glue-pulp-0.1.313-1.el6_3.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
mod_wsgi-3.3-3.pulp.el6.x86_64

How reproducible:
Only when search widget is on the maximum left side of the page.

Steps to Reproduce:
1.For example open Promotion Changeset History.
2.Click on down arrow to open search history dropdown.
3.Verify than part of search history is invisible from left side.
  
If it does not happen, try to drag the right vertical line of search result block (which is under search widget) to left.

Actual results:
Search history results are partly invisible.
Please find attached screenshot.

Expected results:
Search history item's texts should be visible.

Additional info:
This happens because the css class on "div" element which contains search histories has attribute "right: 12px;"
.search .qdropdown.right-menu {
    right: 12px;
}

Also, each search history item "span" element has a 300px width, set by css class:
.search .qdropdown ul li span {
    color: #1CA5D2;
    display: block;
    padding: 4px 10px 4px 24px;
    white-space: nowrap;
    width: 300px;
}
Comment 1 Tomas Strachota 2012-12-18 11:11:54 EST
Seems to be fixed in 1.3.0-1.git.94.15d1b9d.el6
Comment 4 Hayk Hovsepyan 2013-05-07 05:59:04 EDT
Verified in:
'Katello Version: 1.4.2-1.git.1.cf40be3.el6'.
Comment 5 Bryan Kearney 2014-07-02 10:07:24 EDT
This was delivered with 6.0.3, which is the Satellite 6 Beta.

Note You need to log in before you can comment on or make changes to this bug.