Bug 830257 - wrong fstab entry after distribution upgrade
wrong fstab entry after distribution upgrade
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-08 12:32 EDT by Pavel Krivanek
Modified: 2013-01-10 01:49 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-18 09:23:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda logs (59.50 KB, application/x-gzip)
2012-06-08 13:54 EDT, Pavel Krivanek
no flags Details
screenshot of the boot failure (1.50 MB, image/jpeg)
2012-06-09 03:01 EDT, Pavel Krivanek
no flags Details

  None (edit)
Description Pavel Krivanek 2012-06-08 12:32:15 EDT
I did the Fedora distribution upgrade from version 16 to 17 using DVD. I used external USB DVD drive for booting of the upgrade DVD. After the successful upgrade Fedora was not able to boot because Anaconda added this fstab entry:

none                    /vbusbf                 usbfs   rw,devgid=501,devmode=664 0 0

The boot process failed on step "starting /vbusbf" end falled into the rescue mode.
Comment 1 Jesse Keating 2012-06-08 12:51:56 EDT
Please attach the log files from /var/log/anaconda/ on your installed system (assuming you've commented out the fstab entry and booted up).
Comment 2 Pavel Krivanek 2012-06-08 13:54:32 EDT
Created attachment 590479 [details]
anaconda logs
Comment 3 David Lehman 2012-06-08 15:39:04 EDT
How did the mount fail? Does the mountpoint exist? Anaconda does not even write out a new /etc/fstab file when doing an upgrade, so this was in your fstab prior to the upgrade. I'm not sure what you expect us to do to in this case.
Comment 4 Pavel Krivanek 2012-06-09 03:01:54 EDT
Created attachment 590557 [details]
screenshot of the boot failure
Comment 5 Pavel Krivanek 2012-06-09 03:12:41 EDT
The mount point does exist. I did a screenshot of the boot failure. If I try to do "mount -a" in the living system with this uncommented line, I got:
mount: unknown filesystem type 'usbfs'
I looked at the older logs and it seems that you are right, the system mounted vbusbf before the update too but without failure. 

So it seems that it is not a bug in Anaconda. I guess it is related somehow to VirtualBox USB support.

Note You need to log in before you can comment on or make changes to this bug.