Bug 830332 - managed entry doesn't delete linked entry
managed entry doesn't delete linked entry
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: 389-ds-base (Show other bugs)
6.4
Unspecified Unspecified
medium Severity unspecified
: rc
: ---
Assigned To: Rich Megginson
IDM QE LIST
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-08 17:08 EDT by Nathan Kinder
Modified: 2012-07-23 16:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-23 16:29:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nathan Kinder 2012-06-08 17:08:07 EDT
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/389/ticket/358

When you set up managed entry, and delete a user entry, it doesn't delete the linked group entry.

Looks like this was broken by changeset:a5ed82445832092277f5edf2d0440c8d1e931619/389-ds-base

The problem is that #define SLAPI_DELETE_BEPREOP_ENTRY SLAPI_ENTRY_PRE_OP and the delete code doesn't properly manage resetting SLAPI_DELETE_BEPREOP_ENTRY aka SLAPI_ENTRY_PRE_OP for the post operation code, in this case, managed entry.
Comment 1 RHEL Product and Program Management 2012-07-10 02:18:14 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 2 RHEL Product and Program Management 2012-07-10 18:57:40 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 3 Nathan Kinder 2012-07-23 16:29:16 EDT
This was only ever broken in upstream 389, not RHEL.  Closing as NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.