Bug 830334 - Invalid chaining config triggers a disk full error and shutdown
Invalid chaining config triggers a disk full error and shutdown
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: 389-ds-base (Show other bugs)
6.4
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Rich Megginson
Sankar Ramalingam
: ZStream
Depends On:
Blocks: 911474 913144
  Show dependency treegraph
 
Reported: 2012-06-08 17:11 EDT by Nathan Kinder
Modified: 2013-11-21 15:59 EST (History)
6 users (show)

See Also:
Fixed In Version: 389-ds-base-1.2.11.15-14.el6_4
Doc Type: Bug Fix
Doc Text:
Cause: Invalid chaining configuration lead to an incorrect interpretation of an error code. Consequence: The server was triggered to shutdown because it thinks the server ran out of disk space. Fix: Correct the error code. Result: The server does not shutdown when it detects invalid chaining configuration.
Story Points: ---
Clone Of:
: 913144 (view as bug list)
Environment:
Last Closed: 2013-11-21 15:59:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nathan Kinder 2012-06-08 17:11:31 EDT
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/389/ticket/367

If you try and setup chaining using the root DN, the callback returns -2, which is incorrectly seen as a "disk full" error and the DS is automatically shutdown.
Comment 1 RHEL Product and Program Management 2012-07-10 02:18:09 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 2 RHEL Product and Program Management 2012-07-10 19:00:11 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 4 Sankar Ramalingam 2013-01-24 07:03:41 EST
Request you to please add verification steps.
Comment 5 mreynolds 2013-01-24 09:02:37 EST
Setup chaining, and set the root dn (cn=directory manager" as the bind dn:

https://access.redhat.com/knowledge/docs/en-US/Red_Hat_Directory_Server/9.0/html/Administration_Guide/Configuring_Directory_Databases-Creating_and_Maintaining_Database_Links.html

After setting up chaining/database link, make sure the DS is still running.
Comment 11 errata-xmlrpc 2013-11-21 15:59:49 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1653.html

Note You need to log in before you can comment on or make changes to this bug.