Bug 830359 - kernel update to 3.4 breaks graphics (NVIDIA 560ti, using nouveau)
kernel update to 3.4 breaks graphics (NVIDIA 560ti, using nouveau)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
17
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
: 830432 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-08 18:57 EDT by Josh Aas
Modified: 2012-07-09 08:48 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-07 17:54:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josh Aas 2012-06-08 18:57:45 EDT
Description of problem:
I updated Fedora today, which I believe included a kernel update to version 3.4.x, and now when I boot up I just get a black screen. Selecting the previous 3.3.x kernel is a workaround.

Version-Release number of selected component (if applicable):
kernel 3.4.x

How reproducible:
don't know

Steps to Reproduce:
1. Install FC17 update to kernel 3.4
  
Actual results:
black screen

Expected results:
normal graphical boot
Comment 1 Josh Aas 2012-06-08 19:02:45 EDT
Specifically, booting to 3.3.7-1.fc17.x86_64 works, 3.4.0-1.fc17.x86_64 doesn't.
Comment 2 Josh Aas 2012-06-09 11:51:13 EDT
Reading over my report, perhaps I didn't make it clear that the screen is entirely black when I boot with the new kernel. I don't get a command-line prompt.

Also, I have encrypted disks, the first thing I normally see is the disk encryption password field. I don't even see that with the bad kernel.
Comment 3 Ben Skeggs 2012-06-12 17:58:19 EDT
Are you able to boot with "nomodeset 3", login at the console and run "modprobe -r nouveau; modprobe nouveau modeset=1", and then save the dmesg log over ssh?  There's a chance you'll be able to reboot and fetch the last kernel log from /var/log/messages if you can't.

Thanks!
Comment 4 Josh Aas 2012-06-14 22:39:05 EDT
I tried to boot by hitting "e" with the bad kernel selected and adding "set nomodeset=3". I was asked to enter my disk encryption password, then the little Fedora logo that normally fills up during the boot process came up but it never started filling in and the machine is frozen. No command line. Should I be trying something else?

Sorry for the delayed response, was traveling.
Comment 5 Josh Aas 2012-06-14 22:58:40 EDT
I booted into the old kernel, ran updates, then tried booting into the bad kernel again. This time I get a whole bunch of white text, mostly prefixed with numbers like "1.774010". Some other notable lines:

dracut: error: unexpectedly disconnected from boot status daemon
Cannot open font file True

Then at the bottom it asks me "Enter passphrase for /dev/sda2" but it won't accept the root password or my disk encryption password.
Comment 6 Josh Aas 2012-06-14 23:02:49 EDT
The next time I booted up into the bad kernel I didn't get the white text, I got the gray logo screen freeze that I got when I tried nomodeset, and then the next time I got different white text output. I have no idea what in particular is going on here but these randomly changing symptoms for the same start conditions seem like memory corruption to me.

The old kernel continues to boot just fine.
Comment 7 Josh Aas 2012-06-15 12:25:46 EDT
Here is another report of the same problem in the forum. Person has an NVIDIA card, udpated to kernel 3.4 and then can't boot.

[SOLVED] Fedora 17 fresh install - then software update - won' boot to new kernal
http://forums.fedoraforum.org/showthread.php?p=1584443

It's not really solved in that all he did is find a workaround by using an even newer unstable kernel.
Comment 8 WorMzy Tykashi 2012-06-19 17:49:27 EDT
I have the same problem, with the same kernels (anything 3.4+) though I'm using Arch Linux. Have you created a bug report upstream? I was following this one[1] for a while, but the fix suggested by Karol there didn't work for me. You may have better results.

[1] https://bugs.freedesktop.org/show_bug.cgi?id=50175
Comment 9 WorMzy Tykashi 2012-06-19 18:31:36 EDT
Seems like this[2] may be the same problem.

All three of us are using GeForce 560 Ti cards, and are experiencing the problem with 3.4+ kernels.

[2]https://bugs.freedesktop.org/show_bug.cgi?id=51018
Comment 10 Josh Aas 2012-06-20 06:25:52 EDT
Thanks WorMzy - that does seem like exactly the same problem.
Comment 11 Josh Aas 2012-06-26 18:00:51 EDT
Still failing with the latest kernel update (3.4.3).
Comment 12 Josh Aas 2012-07-02 09:27:18 EDT
Still failing with the latest kernel update (3.4.4). I would really like to get kernel updates again.
Comment 13 WorMzy Tykashi 2012-07-02 10:23:00 EDT
Just a heads up: it's fixed upstream (https://git.kernel.org/?p=linux/kernel/git/torvalds/linux.git;a=commitdiff;h=9bd0c15fcfb42f6245447c53347d65ad9e72080b;hp=d42f0349f3fed647c61c2d432e974bbdafcfb3fb), so you can manually apply the patch and compile your own "current" kernel, or you can compile the latest 3.5 RC, which has the fix applied, or you can wait for 3.4.5 to drop, which I'm led to believe will also have the fix applied.

:)
Comment 14 Josh Boyer 2012-07-05 12:07:06 EDT
Ben, I'm going to pull this fix in.  3.4.5 is taking a while to get out.
Comment 15 Josh Boyer 2012-07-05 13:51:38 EDT
Fixed in Fedora git for f16/f17
Comment 16 Fedora Update System 2012-07-05 17:55:55 EDT
kernel-3.4.4-5.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kernel-3.4.4-5.fc17
Comment 17 Fedora Update System 2012-07-05 19:49:52 EDT
kernel-3.4.4-4.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/kernel-3.4.4-4.fc16
Comment 18 Fedora Update System 2012-07-06 17:23:18 EDT
Package kernel-3.4.4-4.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.4.4-4.fc16'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-10319/kernel-3.4.4-4.fc16
then log in and leave karma (feedback).
Comment 19 Fedora Update System 2012-07-07 17:54:29 EDT
kernel-3.4.4-5.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 20 Fedora Update System 2012-07-08 16:51:03 EDT
kernel-3.4.4-4.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 21 Andrey Arapov 2012-07-08 18:05:32 EDT
Just updated to kernel-3.4.4-5.fc17 - it works ! This bug can be closed.

Solution:
[root@P8Z68 ~]# yum update -y
[root@P8Z68 ~]# reboot
[root@P8Z68 ~]# rpm -q --changelog kernel-3.4.4-5.fc17 |grep nouveau |head -1
- Fix breakage in nouveau with nv_two_heads (rhbz 830359)

Thank you!
Comment 22 Josh Aas 2012-07-08 18:59:51 EDT
The update fixed the problem for me, thanks!
Comment 23 Josh Boyer 2012-07-09 08:48:10 EDT
*** Bug 830432 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.