Bug 830406 - "User-configured server refusing to start/autospawn"
"User-configured server refusing to start/autospawn"
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
17
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-09 04:37 EDT by Robin Green
Modified: 2012-08-12 16:24 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-10 09:15:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robin Green 2012-06-09 04:37:45 EDT
Description of problem:
pulseaudio rarely if ever autospawns since I upgraded to F17, so I have to start it manually. It regularly shuts down, as well, so I have to keep restarting it myself.

Version-Release number of selected component (if applicable):
pulseaudio-1.1-9.fc17.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Boot up
2. ps -Afl|grep pulseaudio
  
Actual results:
ps shows that pulseaudio is not running

Expected results:
pulseaudio should be running

Additional info:
It seems to be shutting down when I start it normally due to:
  I: [pulseaudio] core.c: We are idle, quitting...
  I: [pulseaudio] main.c: Daemon shutdown initiated.
I guess this is normal.
Comment 1 Robin Green 2012-06-09 04:39:43 EDT
I don't know if this is relevant, but when I start it manually for the first time, it tends to start with the output device muted, but the relevant mute control is not visible in kmix, only in pavucontrol.
Comment 2 Brendan Jones 2012-06-09 05:51:29 EDT
Exit on idle is normal behaviour but it should restart when requested.

You can cp /etc/pulse/daemon.conf $HOME/.oulse and edit exit-idle-time if you really want to keep it running. You can also change your log-levels and redirect to syslog. man pulse-deamon.conf for details

Just to make sure you don't have autospawn = no in you ~/.pulse/client.conf?
Comment 3 Brendan Jones 2012-06-09 05:51:55 EDT
that is $HOME/.pulse
Comment 4 Robin Green 2012-06-10 09:15:09 EDT
Thanks for the hints, Brendan. This was actually caused by an old file in ~/.pulse that was last modified last year. No idea what created it. When I deleted that file, this issue went away.
Comment 5 Christopher Hassell 2012-08-12 16:24:27 EDT
I have the same problem with an F16/F17 system (and a pure F17 system nearby).  Erase the ~/.pulse directory and no change.  No autospawn... ever.  What in the world *signals* to not autospawn.  What is the "user-configured server" flag??

client.conf

autospawn = yes
daemon-binary = /usr/bin/pulseaudio
extra-arguments = --log-target=syslog

daemon.conf

high-priority = yes
nice-level = -11
realtime-scheduling = yes
realtime-priority = 5
rlimit-nice = 31
rlimit-rtprio = 9
rlimit-rttime = 1000000

Note You need to log in before you can comment on or make changes to this bug.