Bug 830415 - powertop2tuned doesnt work
powertop2tuned doesnt work
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: powertop (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jaroslav Škarvada
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-09 07:13 EDT by fred
Modified: 2012-06-25 20:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-12 10:00:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description fred 2012-06-09 07:13:03 EDT
Description of problem:
powertop2tuned doesnt work

How reproducible:
always

Steps to Reproduce:
1. go to https://fedorahosted.org/tuned/ to see how you can use powertop with tuned
2. Run  powertop2tuned my-profile as root
  
Actual results:
THe program fails due to a file not found error

Expected results:
Program should not fail, partitularly because it's a procedure documented on the main documentation page of the tuned project.

Additional info:
stack trace:
[~] powertop2tuned my-profile                                                                        13:06:17 
Loaded 5 prior measurements
Preparing to take measurements
Measuring 1 time(s) for 20 seconds each
PowerTOP outputing using base filename /tmp/tmpygw8RA-20120609-130620.html
Traceback (most recent call last):
  File "/usr/bin/powertop2tuned", line 234, in <module>
    sys.exit(p.generate(args['new_profile'], args['enable']))
  File "/usr/bin/powertop2tuned", line 183, in generate
    data = self.parseHTML(enable_tunings)
  File "/usr/bin/powertop2tuned", line 147, in parseHTML
    f = open(self.name)
IOError: [Errno 2] No such file or directory: u'/tmp/tmpygw8RA'
Comment 1 Jaroslav Škarvada 2012-06-10 18:00:30 EDT
Thanks, it was caused by latest powertop rebase, we will release update soon.
Comment 2 Jaroslav Škarvada 2012-06-12 10:00:59 EDT
We fixed this upstream thus closing as upstream. Fedora update is on the way:
https://admin.fedoraproject.org/updates/tuned-2.0.1-2.fc17
Comment 3 Fedora Update System 2012-06-12 11:39:02 EDT
tuned-2.0.1-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/tuned-2.0.1-3.fc17
Comment 4 Fedora Update System 2012-06-25 20:37:30 EDT
tuned-2.0.1-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.