Bug 830428 - systemd should obsolete/provide system-setup-keyboard.
systemd should obsolete/provide system-setup-keyboard.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-09 09:28 EDT by Jan Henrik Hasselberg
Modified: 2012-11-07 19:08 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-07 19:08:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Henrik Hasselberg 2012-06-09 09:28:30 EDT
Description of problem:

For unknown reason keyboard was set to English layout when logging in to Gnome 3 today after cold boot. My installation uses English language for menus and applications, but keyboard settings system wide and in local session is set to Norwegian. Changing keyboard settings in control panel and system-config-keyboard did not solve my problem. Same problem existed with Xfce4, with and without GDM3.

Version-Release number of selected component (if applicable):
Linux 3.4.0-1.fc17.x86_64
xorg-x11-server-Xorg-1.12.0-5.fc17.x86_64

How reproducible:
On an updated Fedora 17 instance with Norwegian keyboard, as of 9th June 2012, log into graphical desktop and X resets to English keyboard layout.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
In graphical desktop, keyboard is reset to English layout.

Expected results:
In graphical desktop, keyboard should use system keyboard layout (unless user specify other layout for session).

Additional info:
I noticed /etc/X11/xorg.conf.d/00-system-setup-keyboard.conf pointed to /dev/null
Removing symbolic link, and running system-setup-keyboard, generated new 00-system-setup-keyboard.conf with settings for Norwegian keyboard. After this, keyboard worked. Result below.

-------
#/etc/X11/xorg.conf.d/00-system-setup-keyboard.conf 
# This file is autogenerated by system-setup-keyboard. Any 
# modifications will be lost.

Section "InputClass"
        Identifier      "system-setup-keyboard"
        MatchIsKeyboard "on"
        Option          "XkbModel"      "pc105"
        Option          "XkbLayout"     "no"
#       Option          "XkbVariant"    "(null)"
        Option          "XkbOptions"    "terminate:ctrl_alt_bksp,"
EndSection
-------
Comment 1 Peter Hutterer 2012-06-20 02:18:18 EDT
(In reply to comment #0)
> I noticed /etc/X11/xorg.conf.d/00-system-setup-keyboard.conf pointed to
> /dev/null

systemd does this. Lennart, what's the status on system-setup-keyboard and systemd? Can we retire system-setup-keyboard given that systemd just removes the file it creates anyway?
Comment 2 Kay Sievers 2012-06-20 08:11:53 EDT
Yes, system-setup-keyboard should go away, and systemd will care about that.

I think, the only thing that's missing iat the moment, is to teach anaconda
to call into systemd-localed once, to create the config file initially.

We should drop the Requires: in the X server now, so that s-s-k can be removed,
and we will take care that systemd does all that properly.
Comment 3 Peter Hutterer 2012-06-20 21:33:44 EDT
Can you add a Provides/Obsoletes line to systemd once the remaining issues are fixed? We can update X once it's really gone.
Comment 4 Kay Sievers 2012-10-30 17:45:07 EDT
Systemd obsoletes system-setup-keyboard since quite some while. Reassigning
the bug to get rid of the original package, or just close it from xorgs side,
if it's already done. Thanks!
Comment 5 Peter Hutterer 2012-11-07 19:08:54 EST
Package was retired 31/07/2012, closing as fixed.

Note You need to log in before you can comment on or make changes to this bug.