Bug 830438 - Most of network services do not listen on network interfaces after Fedora starts up or the interface is brought up
Most of network services do not listen on network interfaces after Fedora sta...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
17
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-09 11:08 EDT by Oleg Samarin
Modified: 2012-06-25 13:27 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-25 13:27:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
NetworkManager dispatcing script for nfs-server (109 bytes, application/octet-stream)
2012-06-09 11:08 EDT, Oleg Samarin
no flags Details

  None (edit)
Description Oleg Samarin 2012-06-09 11:08:51 EDT
Created attachment 590618 [details]
NetworkManager dispatcing script for nfs-server

Description of problem:

1. After Fedora starts up most of network services (named, squid, nfs-server etc.)
do not listen to inbound requests on network interfaces. 

2. After the services have been restarted they usually start working

3. After some network interface are brought down and then up the services do not start listening on it.

How reproducible:
Install Fedora to a computer with one or several network interface. Install and configure bind, squid and nfs-server.

Steps to Reproduce:
1. Start Fedora
2. Try to use these service from another computer (nslookup, firefox or mount -t nfs4)
  
Actual results:
No responce from these services

Expected results:
Working services

Additional info:

Because by default Fedora uses NetworkManager instead of /etc/rc.d/init.d/network script, most of network services start before NetworkManager brings the network interfaces up so they do not start listen on these interfaces.

There are several scripts in /etc/NetworkManager/dispatcher.d. They should notify network services (named, squid etc.) that some network interface has brought up or down. Unfortunately, they all run executables from /sbin directory which does not more exist in Fedora 17. So these scripts do not work at all in Fedora 17.

And there is no notification script for nfs-server.

After I modified these scripts, having changed 

'/sbin/ip' to 'ip'
'/sbin/service' to 'service'
'/sbin/systemctl' to 'systemctl'

and having provided a script 20-nfs-server (see attatchment), all my services started working after Fedora startup
Comment 1 Dan Winship 2012-06-13 15:02:18 EDT
(In reply to comment #0)
> Unfortunately, they all run executables from /sbin
> directory which does not more exist in Fedora 17.

/sbin should be a symlink to /usr/sbin. It sounds like your machine is broken. Did you use a non-supported method to upgrade from 16 to 17? If so, it might not have done all the necessary cleanup/fixing needed for the / -> /usr move... You should have symlinks for /bin, /lib, /lib64 (on x86_64), and /sbin.
Comment 2 Oleg Samarin 2012-06-14 13:36:33 EDT
You are right. The symlink /sbin exists in my machine. There was another
reason for dispatcher scripts not to work: systemctl resides in /usr/bin
rather /sbin, but the scripts try to run /sbin/systemctl.
Comment 3 Dan Winship 2012-06-14 14:29:38 EDT
OK. The scripts in /etc/NetworkManager/dispatcher.d/ aren't part NetworkManager though. They're provided by other packages, to be used by NetworkManager. So you need to file bugs against those other packages.
Comment 4 Dan Winship 2012-06-25 13:27:36 EDT
closing per previous comment: the bugs are in packages other than NetworkManager

Note You need to log in before you can comment on or make changes to this bug.