Bug 830470 - Evolution keeps prompting for the password
Evolution keeps prompting for the password
Status: CLOSED DUPLICATE of bug 830468
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
17
i686 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-09 18:56 EDT by mark gress
Modified: 2012-06-14 03:10 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-13 03:20:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mark gress 2012-06-09 18:56:08 EDT
Description of problem: I can send email, I cannot receive it.  But despite this, the prompt asking for the password keeps coming up.  It saves the password, but after about a minute it comes up again wanting the password.


Version-Release number of selected component (if applicable):  Evolution 3.4.2


How reproducible:  Always


Steps to Reproduce:  Create a new account in Evolution or import an old one.  Does the same thing.
  
Actual results:  Annoying


Expected results:  Store the password, send and receive emails as normal.


Additional info:  All software packages are up to date, whatever packages were marked as dependencies is what got installed.
Comment 1 mark gress 2012-06-09 19:00:08 EDT
In addition to being able to send emails outbound, I know it is communicating with both the pop and smtp servers because when I query the servers in the account settings to see what authentication is required by the email server, various options get striked out letting me know which is the proper one to use.
Comment 2 mark gress 2012-06-09 22:43:57 EDT
I got the email issue solved, but I still can't get it to stop asking for the keyring.  It does it every time the computer is restarted.  I suspect that it probably would work correctly, if this didn't keep happening:

https://bugzilla.redhat.com/show_bug.cgi?id=830468

I installed Seahorse, and that seemed to help smooth things over a bit, but not enough to make evolution seamless, as it should be.
Comment 3 Milan Crha 2012-06-11 04:27:32 EDT
Thanks for a bug report and updates on it. If the gnome-keyring is crashing in the background, then it makes sense you are asked for your keyring password whenever evolution requires it.

That's why I would mark this as a duplicate of bug #830468, but before that, could you run evolution from a terminal and see whether any keyring related runtime warnings are printed there, please? That way we can confirm that this is related to your issues with key-ring.
Comment 4 mark gress 2012-06-12 21:36:35 EDT
Alright.  What I did here was launch Evolution in konsole, enter the keyring password at the prompt, then close the program.  This is what popped up.

[user@localhost ~]$ evolution
GLib-GIO-Message: Using the 'memory' GSettings backend.  Your settings will not be saved or shared with other applications.

** (evolution:1025): WARNING **: Unrecognized junk filter name 'Bogofilter' in GSettings
[user@localhost ~]$
Comment 5 Milan Crha 2012-06-13 03:20:05 EDT
Thanks for the update. There is actually no warning from keyring. The "using 'memory' GSettings backend" is shown when you do not have installed dconf. It can also happen if you compile your own glib, but do not compile dconf against it. I do not think it's related to your keyring issue. I'm marking this as a duplicate of the crash bug.

*** This bug has been marked as a duplicate of bug 830468 ***
Comment 6 mark gress 2012-06-13 23:14:32 EDT
Thanks for being so prompt and keeping an eye on this.

So theoretically, once the other bug is fixed the keyring will stop prompting for the password?
Comment 7 Milan Crha 2012-06-14 03:10:41 EDT
(In reply to comment #6)
> So theoretically, once the other bug is fixed the keyring will stop
> prompting for the password?

I guess so, but I do not have any prove for it. Please, feel free to reopen this bug if a fix in keyring will not help.

Note You need to log in before you can comment on or make changes to this bug.