Bug 830495 - Gluster - Backend: RDMA-only volumes are created as TCP+RDMA
Gluster - Backend: RDMA-only volumes are created as TCP+RDMA
Status: CLOSED CURRENTRELEASE
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
unspecified
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Kanagaraj
Sudhir D
gluster, storage
:
Depends On:
Blocks: 825285
  Show dependency treegraph
 
Reported: 2012-06-10 04:17 EDT by Daniel Paikov
Modified: 2016-04-18 06:05 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-10 03:42:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine.log (35.60 KB, application/x-gzip)
2012-06-10 04:17 EDT, Daniel Paikov
no flags Details

  None (edit)
Description Daniel Paikov 2012-06-10 04:17:07 EDT
Created attachment 590703 [details]
engine.log

When trying to create an RDMA-only volume from GUI, the volume is created as TCP+RDMA.

The command sent to VDSM looks like this:
MainProcess|Thread-143046::DEBUG::2012-06-10 08:08:16,188::__init__::1164::Storage.Misc.excCmd::(_log) '/usr/sbin/gluster --mode=script volume create vol12 transport TCP,RDMA 10.35.64.205:/vol12' (cwd None)

And gluster volume info looks like this:
[root@dbotzer-reporting vdsm]# gluster volume info vol12
 
Volume Name: vol12
Type: Distribute
Volume ID: 22dfaab6-80ca-4db8-a6c2-52ae443474b3
Status: Created
Number of Bricks: 1
Transport-type: tcp,rdma
Bricks:
Brick1: 10.35.64.205:/vol12
Options Reconfigured:
auth.allow: *
nfs.disable: off
Comment 2 Kanagaraj 2012-06-11 06:04:55 EDT
Fixed in Patch.

http://gerrit.ovirt.org/#/c/5227/
Comment 3 Daniel Paikov 2012-06-18 05:03:32 EDT
RDMA is no longer exposed in GUI as of rhsc-2.0.techpreview1-0.scratch. Unable to reproduce.

Note You need to log in before you can comment on or make changes to this bug.