Bug 830509 - xine-lib-1.1.21 is available
xine-lib-1.1.21 is available
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xine-lib (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kevin Kofler
Fedora Extras Quality Assurance
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-10 05:48 EDT by Upstream Release Monitoring
Modified: 2012-07-30 01:05 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-30 01:05:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bump to 1.1.21 and libbluray support (1.39 KB, patch)
2012-06-12 18:37 EDT, Xavier Bachelot
no flags Details | Diff

  None (edit)
Description Upstream Release Monitoring 2012-06-10 05:48:00 EDT
Latest upstream release: 1.1.21
Current version in Fedora Rawhide: 1.1.20.1
URL: http://sourceforge.net/api/file/index/project-name/xine/mtime/desc/limit/100/rss

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring
Comment 1 Xavier Bachelot 2012-06-12 18:37:17 EDT
Created attachment 591293 [details]
bump to 1.1.21 and libbluray support
Comment 2 Xavier Bachelot 2012-06-12 18:38:06 EDT
Here's a simple patch to update to latest version and add libbluray support. I'm not attaching the corresponding patch for that other repository counterpart package, it's really straighforward and would be off-topic here anyway.
Comment 3 Kevin Kofler 2012-06-12 19:02:28 EDT
Thanks. I'll commit and build ASAP, but I want to verify that there isn't any new encumbered stuff smuggled into the tarball. (Sorry, but when doing 1.1.19, I noticed some suspicious stuff that had crept in over time, so now I prefer being overly careful and paranoid.)
Comment 4 Kevin Kofler 2012-06-23 06:17:15 EDT
I verified that no new encumbered stuff was added to the upstream tarball and pushed the patch to Rawhide, but it looks like the Rawhide buildroots are broken yet again, so the build failed. I'll have to retry later.

Another thing I wonder is whether it'd be legally acceptable to add a versioned Conflicts: xine-lib-extras-freeworld < 1.1.21-2 to xine-lib. For some reason, the DVD input plugin is in RPM Fusion, but libdvdnav and libdvdread in Fedora, and it doesn't make a lot of sense to have BluRay support in Fedora and not DVD support. Of course the support isn't all that useful without an MPEG decoder, but the same goes for the DVB (digital TV) input plugin which is in Fedora already (and supposedly those inputs can all be used with a hardware MPEG decoder). So I'd like to move the DVD input plugin to Fedora, GStreamer already ships dvdnav support in Fedora, it even explicitly got picked into gstreamer-plugins-bad-free.
Comment 5 Rex Dieter 2012-06-23 06:37:55 EDT
adding such a Conflicts would be fine, imo.
Comment 6 Fedora Update System 2012-07-21 09:19:04 EDT
xine-lib-1.1.21-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/xine-lib-1.1.21-2.fc17
Comment 7 Fedora Update System 2012-07-21 10:04:35 EDT
xine-lib-1.1.21-2.fc16.1 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/xine-lib-1.1.21-2.fc16.1
Comment 8 Fedora Update System 2012-07-21 18:53:31 EDT
Package xine-lib-1.1.21-2.fc16.1:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xine-lib-1.1.21-2.fc16.1'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-10963/xine-lib-1.1.21-2.fc16.1
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2012-07-30 01:00:45 EDT
xine-lib-1.1.21-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2012-07-30 01:05:22 EDT
xine-lib-1.1.21-2.fc16.1 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.