Bug 830521 - SELinux is preventing /usr/bin/df from 'getattr' accesses on the blk_file /dev/dm-2.
SELinux is preventing /usr/bin/df from 'getattr' accesses on the blk_file /de...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:d3aae29bc8a8ddf394fb2dd86cb...
:
Depends On:
Blocks: 927339
  Show dependency treegraph
 
Reported: 2012-06-10 06:41 EDT by Stefan Jensen
Modified: 2013-03-25 13:16 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 927339 (view as bug list)
Environment:
Last Closed: 2012-06-18 12:25:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Jensen 2012-06-10 06:41:49 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.4.0-1.fc17.x86_64
time:           So 10 Jun 2012 12:41:15 CEST

description:
:SELinux is preventing /usr/bin/df from 'getattr' accesses on the blk_file /dev/dm-2.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If sie denken, dass df standardmässig erlaubt sein sollte, getattr Zugriff auf dm-2 blk_file zu erhalten.
:Then sie sollten dies als Fehler melden.
:Um diesen Zugriff zu erlauben, können Sie ein lokales Richtlinien-Modul erstellen.
:Do
:zugriff jetzt erlauben, indem Sie die nachfolgenden Befehle ausführen:
:# grep df /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:logwatch_t:s0-s0:c0.c1023
:Target Context                system_u:object_r:fixed_disk_device_t:s0
:Target Objects                /dev/dm-2 [ blk_file ]
:Source                        df
:Source Path                   /usr/bin/df
:Port                          <Unbekannt>
:Host                          (removed)
:Source RPM Packages           coreutils-8.15-6.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-128.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed)
:                              3.4.0-1.fc17.x86_64 #1 SMP Sun Jun 3 06:35:17 UTC
:                              2012 x86_64 x86_64
:Alert Count                   3
:First Seen                    So 10 Jun 2012 12:40:14 CEST
:Last Seen                     So 10 Jun 2012 12:40:14 CEST
:Local ID                      4d4a74d4-30cf-474d-9905-6f343d89ea42
:
:Raw Audit Messages
:type=AVC msg=audit(1339324814.625:136): avc:  denied  { getattr } for  pid=3938 comm="df" path="/dev/dm-2" dev="devtmpfs" ino=22710 scontext=system_u:system_r:logwatch_t:s0-s0:c0.c1023 tcontext=system_u:object_r:fixed_disk_device_t:s0 tclass=blk_file
:
:
:type=SYSCALL msg=audit(1339324814.625:136): arch=x86_64 syscall=lstat success=no exit=EACCES a0=1523aa0 a1=7fffcd474e30 a2=7fffcd474e30 a3=1000 items=0 ppid=3936 pid=3938 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=3 comm=df exe=/usr/bin/df subj=system_u:system_r:logwatch_t:s0-s0:c0.c1023 key=(null)
:
:Hash: df,logwatch_t,fixed_disk_device_t,blk_file,getattr
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Miroslav Grepl 2012-06-11 07:59:33 EDT
It looks like something what we could dontaudit.

Does everything work correctly?
Comment 2 Stefan Jensen 2012-06-11 08:43:52 EDT
Yes, everything works correctly.
Comment 3 Daniel Walsh 2012-06-11 09:13:20 EDT
I don't care if it is dontaudited or allowed, not really something we should be concerned with.
Comment 4 Stefan Jensen 2012-06-18 12:25:50 EDT
Fixed with selinux-policy-targeted-3.10.0-130.fc17.noarch

Thanks!

Note You need to log in before you can comment on or make changes to this bug.