Bug 830539 - webadmin [Import More than Once]: when importing the vm to a different DC we get a wrong warning in UI
webadmin [Import More than Once]: when importing the vm to a different DC we ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
x86_64 Linux
high Severity medium
: ---
: ---
Assigned To: Gilad Chaplik
vvyazmin@redhat.com
virt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-10 09:25 EDT by Dafna Ron
Modified: 2015-06-19 01:20 EDT (History)
11 users (show)

See Also:
Fixed In Version: si17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen shot (55.75 KB, image/jpeg)
2012-06-10 09:25 EDT, Dafna Ron
no flags Details

  None (edit)
Description Dafna Ron 2012-06-10 09:25:53 EDT
Created attachment 590745 [details]
screen shot

Description of problem:

when I import a vm to a different DC (vm created in NFS and importing more then once to an iscsi DC) we get an exclimation mark on the vm with the following warning: 

Use a separate import operation for the marked VMs or Apply "Collapse Snapshots" for all VMs

***the collaps snapshot is automatically marked btw*** 

Version-Release number of selected component (if applicable):

si4

How reproducible:

100%

Steps to Reproduce:
1. create nfs domain and create a vm -> expor the vm
2. create iscsi domain and import the vm that was created in nfs from the export domain 
3.
  
Actual results:

we get an highlated unrelated warning

Expected results:

we should not get this error

Additional info:screen shot
Comment 1 Gilad Chaplik 2012-06-12 05:26:47 EDT
Einav, what is the new logic of showing this warning message?
Comment 2 Einav Cohen 2012-06-13 10:56:03 EDT
This warning message appears when attempting to import VMs with (thinly-provisioned) disks that have RAW volume-format to an iSCSI storage domain.
Import can be done only if the volume-format of the disks is converted from RAW to COW, and it cannot be done unless collapsing the snapshots of the imported VM.

We implemented this warning "mechanism" in rhev-m 3.0.

Andrew: I see that you acked this BZ; has something changed since rhev-m 3.0 in that sense? Any chance that this message isn't needed anymore?
Comment 3 Dafna Ron 2012-06-13 11:00:41 EDT
to my understanding, we only support collaps snapshot for "import more than once" hence the collaps is automatically checked when the vm already exists. 
so if this warning is needed we for other cases we should just fix the code to not show the warning when collaps is checked.
Comment 4 Einav Cohen 2012-07-16 03:31:24 EDT
(In reply to comment #3)
> to my understanding, we only support collaps snapshot for "import more than
> once" hence the collaps is automatically checked when the vm already exists. 

Not exactly: It is the other way around: "import more than once" is supported only with "collapse snapshots" - this is why when importing more than once, the "collapse snapshots" is automatically checked.
"Collapse snapshots" is supported also for importing "regularly", as is, i.e. not "more than once" (check rhev-m 3.0, for example, in which we didn't have "import more than once" at all).
Moreover, the case that I detailed in comment #2 is supported *only* with "collapse snapshots", and it has nothing to do with "import more than once" - I am talking about a regular, "as is" import here.

> so if this warning is needed we for other cases we should just fix the code
> to not show the warning when collaps is checked.

Dafna, according to my explanation above: Can this bug be closed?
Comment 5 Dafna Ron 2012-07-16 03:43:19 EDT
> Dafna, according to my explanation above: Can this bug be closed?

no. 
if collapse snapshot is marked as default when we import more than once than this warning should not appear. 
keeping this error when collapse is checked and greyed out is confusing to the user.
Comment 6 Einav Cohen 2012-07-16 04:51:27 EDT
indeed - this warning message should appear only when the check-box is enabled *and un-checked*. In this case it is disabled and checked, therefore no reason to display it.

This message should either be removed, or a different explanation should appear in order to explain why the "Collapse Snapshots" check-box is checked and disabled (not a must IMO - removing the warning should be enough).

Also, the exclamation marks next to the items in the grid should probably be removed as well, or have a correct tool-tip.
*** Note: This is about a scenario in which *all* VMs in the Import dialog either:
1. already exist in the system, or:
2. have thinly-provisioned disks with RAW volume-format, being imported to an iSCSI storage domain.

[If we have one VM (or more) within the Import dialog that neither #1 nor #2 are applicable for it, the "Collapse Snapshots" check-box should be enabled and un-checked with the relevant warning. Once checked, the warning should disappear]

Note that things might change a bit once Bug 840280 is solved - need to follow.
Comment 7 Gilad Chaplik 2012-08-19 05:26:56 EDT
pushed upstream (http://gerrit.ovirt.org/#/c/7313/)
Comment 9 vvyazmin@redhat.com 2012-09-06 07:13:00 EDT
Verified on RHEVM 3.1 - SI17

RHEVM: rhevm-3.1.0-15.el6ev.noarch
VDSM: vdsm-4.9.6-32.0.el6_3.x86_64
LIBVIRT: libvirt-0.9.10-21.el6_3.4.x86_64
QEMU & KVM: qemu-kvm-rhev-0.12.1.2-2.295.el6_3.2.x86_64
SANLOCK: sanlock-2.3-3.el6_3.x86_64

Note You need to log in before you can comment on or make changes to this bug.