Bug 830541 - webadmin [Import More than Once]: cannot uncheck the 'clone all vm's' checkbox in case the vm already exists in setup
webadmin [Import More than Once]: cannot uncheck the 'clone all vm's' checkbo...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Gilad Chaplik
Dafna Ron
virt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-10 09:35 EDT by Dafna Ron
Modified: 2015-09-22 09 EDT (History)
7 users (show)

See Also:
Fixed In Version: si10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:07:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen shot (46.97 KB, image/jpeg)
2012-06-10 09:35 EDT, Dafna Ron
no flags Details

  None (edit)
Description Dafna Ron 2012-06-10 09:35:27 EDT
Created attachment 590747 [details]
screen shot

Description of problem:

if we try to import vm more then once we cannot uncheck the 'clone all vms' checkbox in the UI import dialoge. 

Version-Release number of selected component (if applicable):

si4

How reproducible:

100%

Steps to Reproduce:
1. try to import a vm more then once
2.
3.
  
Actual results:

when the vm already exists the 'clone all vms' checkbox is already check (it should be unchecked). and it can not be unchecked. 

Expected results:

1. checkbix should be unchecked as default 
2. we should be able to uncheck it

Additional info: screen shot
Comment 1 Gilad Chaplik 2012-06-10 09:52:08 EDT
why is it a bug? you can't import it unless you clone it (it's part of the design)
Comment 2 Dafna Ron 2012-06-10 10:00:03 EDT
1. from wiki: 

    Add 'clone all entities' check box to Import Entity Dialog 
        In case checked: 
            (in import VM) The 'collapse all snapshots' checkbox should be checked and disabled.
            A suffix textbox should be added (the suffix will be added to all VMs' names). 
    Add 'clone only existing entities' check box to Import Entity Dialog: 
        In case checked: 
            (in import VM) A label will be shown to user that indicates that the cloned VMs' snapshots will be collapsed.
            A suffix textbox should be added (the suffix will be added to all VMs names). 

2. working from test case:
https://tcms.engineering.redhat.com/case/146378/?from_plan=5756

case says that the checkbox should be unchecked by default. 

if only clone is allowed no one documented it.
Comment 3 Gilad Chaplik 2012-06-10 10:05:39 EDT
you're right, but this 'enhancement' is pretty straightforward (unless you object to it), I will change the docs accordingly, and we can close the bug.
Comment 7 Ayal Baron 2012-06-17 05:43:06 EDT
Looking at the screen shot, I have no idea what 'clone all vms' even means.
seems wrong (disks are automatically cloned due to the collapse all snapshots checkbox).
Comment 8 Gilad Chaplik 2012-06-19 09:00:10 EDT
we (Dafna, Dan & Simon) decided that the checkboxes will always we enabled.
Comment 10 Dafna Ron 2012-07-12 12:06:56 EDT
verified on si10. 
we are able to remove the tag and a vm already exists error is shown when removing the tag.

Note You need to log in before you can comment on or make changes to this bug.