Bug 830561 - ovirt-engine-backend: after import more than once vm failed because of vdsm restart we rolled back but failed to unlock the vm
ovirt-engine-backend: after import more than once vm failed because of vdsm r...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
x86_64 Linux
high Severity medium
: ---
: ---
Assigned To: Gilad Chaplik
Dafna Ron
infra virt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-10 12:30 EDT by Dafna Ron
Modified: 2015-09-22 09 EDT (History)
9 users (show)

See Also:
Fixed In Version: si8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 14:58:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs (199.20 KB, application/x-gzip)
2012-06-10 12:32 EDT, Dafna Ron
no flags Details

  None (edit)
Description Dafna Ron 2012-06-10 12:30:03 EDT
Description of problem:

import more than once a vm failed because of vdsm restart
backend rolled back on task but failed to unlock the vm:

2012-06-07 19:16:08,186 ERROR [org.ovirt.engine.core.bll.VmHandler] (pool-10-thread-48) [1d397b11] Trying to unlock vm A in status Down - not moving to down!


Version-Release number of selected component (if applicable):

si4

How reproducible:

100%

Steps to Reproduce:
1. import vm more than once 
2. restart vdsm 
3.
  
Actual results:

vm is stuck in image lock without disks

Expected results:

we should be able to unlock vm status

Additional info: backend and vdsm logs attached


2012-06-07 19:16:08,150 INFO  [org.ovirt.engine.core.bll.EntityAsyncTask] (pool-10-thread-48) [1d397b11] EntityAsyncTask::EndCommandAction [within thread]context: Attempting to 
EndAction ImportVm
2012-06-07 19:16:08,178 ERROR [org.ovirt.engine.core.bll.ImportVmCommand] (pool-10-thread-48) [1d397b11] Ending command with failure: org.ovirt.engine.core.bll.ImportVmCommand
2012-06-07 19:16:08,186 ERROR [org.ovirt.engine.core.bll.VmHandler] (pool-10-thread-48) [1d397b11] Trying to unlock vm A in status Down - not moving to down!
2012-06-07 19:16:08,189 ERROR [org.ovirt.engine.core.bll.SPMAsyncTask] (QuartzScheduler_Worker-57) [1d397b11] BaseAsyncTask::LogEndTaskFailure: Task 63229ad4-929e-40d9-a3b6-b998
edbb76e9 (Parent Command ImportVm, Parameters Type org.ovirt.engine.core.common.asynctasks.AsyncTaskParameters) ended with failure:
-- Result: cleanSuccess
-- Message: VDSGenericException: VDSTaskResultNotSuccessException: TaskState contained successful return code, but a non-success result ('cleanSuccess').,
-- Exception: VDSGenericException: VDSTaskResultNotSuccessException: TaskState contained successful return code, but a non-success result ('cleanSuccess').
2012-06-07 19:16:08,193 INFO  [org.ovirt.engine.core.bll.EntityAsyncTask] (QuartzScheduler_Worker-57) [1d397b11] EntityAsyncTask::EndActionIfNecessary: All tasks of entity 06511
288-36e7-4293-a7de-1cf47dbb422a has ended -> executing EndAction
Comment 1 Dafna Ron 2012-06-10 12:32:18 EDT
Created attachment 590764 [details]
logs
Comment 3 Dafna Ron 2012-07-01 11:50:09 EDT
verified on si8 - vm was removed once we recovered

Note You need to log in before you can comment on or make changes to this bug.