Bug 830567 - [abrt] python-2.7.3-6.fc17: link_before: Process /usr/bin/python2.7 was killed by signal 11 (SIGSEGV)
[abrt] python-2.7.3-6.fc17: link_before: Process /usr/bin/python2.7 was kille...
Status: CLOSED DUPLICATE of bug 827658
Product: Fedora
Classification: Fedora
Component: dbus (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
abrt_hash:4eeee42d1a02ba298991793266e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-10 13:23 EDT by Skouloudakis.P
Modified: 2013-03-05 23:08 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-10 15:36:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (52.11 KB, text/plain)
2012-06-10 13:23 EDT, Skouloudakis.P
no flags Details
File: maps (60.88 KB, text/plain)
2012-06-10 13:23 EDT, Skouloudakis.P
no flags Details
File: dso_list (13.23 KB, text/plain)
2012-06-10 13:23 EDT, Skouloudakis.P
no flags Details
File: build_ids (5.45 KB, text/plain)
2012-06-10 13:23 EDT, Skouloudakis.P
no flags Details

  None (edit)
Description Skouloudakis.P 2012-06-10 13:23:32 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        /usr/bin/python /usr/bin/radiotray
crash_function: link_before
executable:     /usr/bin/python2.7
kernel:         3.3.6-3.fc17.x86_64
pid:            2608
pwd:            /usr/lib/python2.7/site-packages/radiotray
time:           Κυρ 10 Ιούν 2012 08:19:05 μμ EEST
uid:            1000
username:       Panos
var_log_messages: Jun 10 20:19:06 fedora abrt[2619]: Saved core dump of pid 2608 (/usr/bin/python2.7) to /var/spool/abrt/ccpp-2012-06-10-20:19:05-2608 (38752256 bytes)
xsession_errors: /usr/lib/python2.7/site-packages/radiotray/SysTray.py:185: GtkWarning: IA__gdk_window_get_root_coords: assertion `GDK_IS_WINDOW (window)' failed

backtrace:      Text file, 53356 bytes
build_ids:      Text file, 5576 bytes
dso_list:       Text file, 13545 bytes
maps:           Text file, 62343 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/Panos/2

core_backtrace:
:d804f8ee47797da9213a92f00cd095ecada8d79f 0x273dc - libdbus-1.so.3 -
:d804f8ee47797da9213a92f00cd095ecada8d79f 0x27429 - libdbus-1.so.3 -
:d804f8ee47797da9213a92f00cd095ecada8d79f 0x1672a - libdbus-1.so.3 -
:d804f8ee47797da9213a92f00cd095ecada8d79f 0x16b98 - libdbus-1.so.3 -
:d804f8ee47797da9213a92f00cd095ecada8d79f 0x16aac - libdbus-1.so.3 -
:d804f8ee47797da9213a92f00cd095ecada8d79f 0x16f9e - libdbus-1.so.3 -
:d804f8ee47797da9213a92f00cd095ecada8d79f 0x170ad - libdbus-1.so.3 -
:d804f8ee47797da9213a92f00cd095ecada8d79f 0x14138 - libdbus-1.so.3 -
:d804f8ee47797da9213a92f00cd095ecada8d79f 0x1bd2f - libdbus-1.so.3 -
:d804f8ee47797da9213a92f00cd095ecada8d79f 0x23bd2 - libdbus-1.so.3 -
:d804f8ee47797da9213a92f00cd095ecada8d79f 0x23cf1 - libdbus-1.so.3 -
:d804f8ee47797da9213a92f00cd095ecada8d79f 0xc484 - libdbus-1.so.3 -
:d804f8ee47797da9213a92f00cd095ecada8d79f 0xd05e dbus_connection_get_dispatch_status libdbus-1.so.3 -
:80dcf30321dbc04511d9cbf399a83b8f3dc75d5d 0xabc3 - libdbus-glib-1.so.2 -
:e5945f7dae3fc83ad499da1ea5a464bfa0e68202 0x471ef g_main_context_prepare libglib-2.0.so.0 -
:e5945f7dae3fc83ad499da1ea5a464bfa0e68202 0x478db - libglib-2.0.so.0 -
:e5945f7dae3fc83ad499da1ea5a464bfa0e68202 0x47e12 g_main_loop_run libglib-2.0.so.0 -
:f6d72221cbd08cb36bb88823d33deb2024f2bee3 0x149d67 gtk_main libgtk-x11-2.0.so.0 -
:e4ee09219dd69e5a1f6b06fb78c7488a3a6260df 0x1a65a8 - _gtk.so -
:efb4769976ac3cc8192277706894a2d7b3256ed1 0xdce46 PyEval_EvalFrameEx libpython2.7.so.1.0 -
:efb4769976ac3cc8192277706894a2d7b3256ed1 0xdcd61 PyEval_EvalFrameEx libpython2.7.so.1.0 -
:efb4769976ac3cc8192277706894a2d7b3256ed1 0xddb2f PyEval_EvalCodeEx libpython2.7.so.1.0 -
:efb4769976ac3cc8192277706894a2d7b3256ed1 0x6d7b6 - libpython2.7.so.1.0 -
:efb4769976ac3cc8192277706894a2d7b3256ed1 0x49a7e PyObject_Call libpython2.7.so.1.0 -
:efb4769976ac3cc8192277706894a2d7b3256ed1 0x58090 - libpython2.7.so.1.0 -
:efb4769976ac3cc8192277706894a2d7b3256ed1 0x49a7e PyObject_Call libpython2.7.so.1.0 -
:efb4769976ac3cc8192277706894a2d7b3256ed1 0x9d332 - libpython2.7.so.1.0 -
:efb4769976ac3cc8192277706894a2d7b3256ed1 0x9cfcc - libpython2.7.so.1.0 -
:efb4769976ac3cc8192277706894a2d7b3256ed1 0x49a7e PyObject_Call libpython2.7.so.1.0 -
:efb4769976ac3cc8192277706894a2d7b3256ed1 0xd93f3 PyEval_EvalFrameEx libpython2.7.so.1.0 -
:efb4769976ac3cc8192277706894a2d7b3256ed1 0xdcd61 PyEval_EvalFrameEx libpython2.7.so.1.0 -
:efb4769976ac3cc8192277706894a2d7b3256ed1 0xddb2f PyEval_EvalCodeEx libpython2.7.so.1.0 -
:efb4769976ac3cc8192277706894a2d7b3256ed1 0xddc02 PyEval_EvalCode libpython2.7.so.1.0 -
:efb4769976ac3cc8192277706894a2d7b3256ed1 0xf6baa - libpython2.7.so.1.0 -
:efb4769976ac3cc8192277706894a2d7b3256ed1 0xf79a2 PyRun_FileExFlags libpython2.7.so.1.0 -
:efb4769976ac3cc8192277706894a2d7b3256ed1 0xf83bb PyRun_SimpleFileExFlags libpython2.7.so.1.0 -
:efb4769976ac3cc8192277706894a2d7b3256ed1 0x109892 Py_Main libpython2.7.so.1.0 -

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=2
:HOSTNAME=fedora
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:SHELL=/bin/bash
:TERM=dumb
:HISTSIZE=1000
:GNOME_KEYRING_CONTROL=/run/user/Panos/keyring-jMV4EO
:QT_GRAPHICSSYSTEM_CHECKED=1
:IMSETTINGS_MODULE=none
:USER=Panos
:LIBGL_DRIVERS_PATH=/usr/lib/dri:/usr/lib64/dri
:USERNAME=Panos
:MAIL=/var/spool/mail/Panos
:PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/home/Panos/.local/bin:/home/Panos/bin
:DESKTOP_SESSION=gnome
:QT_IM_MODULE=xim
:PWD=/home/Panos
:XMODIFIERS=@im=none
:GNOME_KEYRING_PID=835
:LANG=en_US.utf8
:GDM_LANG=en_US.utf8
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:XDG_SEAT=seat0
:HOME=/home/Panos
:SHLVL=1
:LOGNAME=Panos
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-zHwfEwhdQK,guid=f6015882982b81926a1f1e9000000036
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/Panos
:DISPLAY=:0
:XAUTHORITY=/var/run/gdm/auth-for-Panos-eSd8Nu/database
:_=/usr/bin/gnome-session
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/839,unix/unix:/tmp/.ICE-unix/839
:GPG_AGENT_INFO=/run/user/Panos/keyring-jMV4EO/gpg:0:1
:SSH_AUTH_SOCK=/run/user/Panos/keyring-jMV4EO/ssh
:LC_TIME=el_GR.utf8
:LC_NUMERIC=el_GR.utf8
:LC_MONETARY=el_GR.utf8
:LC_MEASUREMENT=el_GR.utf8
:GJS_DEBUG_OUTPUT=stderr
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/radiotray.desktop
:GIO_LAUNCHED_DESKTOP_FILE_PID=2608

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 31343                processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       31343                31343                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/null
:pos:	0
:flags:	0100000
:1:/home/Panos/.xsession-errors
:pos:	123846
:flags:	0102002
:2:/home/Panos/.xsession-errors
:pos:	123846
:flags:	0102002
:3:/home/Panos/.local/share/radiotray/radiotray.log
:pos:	1700978
:flags:	0102001
:4:socket:[31451]
:pos:	0
:flags:	02004002
:5:pipe:[31452]
:pos:	0
:flags:	00
:6:pipe:[31452]
:pos:	0
:flags:	04001
:7:socket:[31450]
:pos:	0
:flags:	02004002
:8:anon_inode:[eventfd]
:pos:	0
:flags:	02004002

smolt_data:
:
:
:General
:=================================
:UUID: 48eeaa27-b639-48a1-93e4-129f3c47aa5f
:OS: Fedora release 17 (Beefy Miracle)
:Default run level: Unknown
:Language: en_US.utf8
:Platform: x86_64
:BogoMIPS: 4589.22
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM) i5-2410M CPU @ 2.30GHz
:CPU Stepping: 7
:CPU Family: 6
:CPU Model Num: 42
:Number of CPUs: 4
:CPU Speed: 2301
:System Memory: 3937
:System Swap: 0
:Vendor: Acer
:System: Aspire 7750G V1.07
:Form factor: Notebook
:Kernel: 3.3.6-3.fc17.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Permissive
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:7241:4133:1294) pci, None, PCI/ISA, HM65 Express Chipset Family LPC Controller
:(32902:7202:4133:1294) pci, None, SERIAL, 6 Series/C200 Series Chipset Family SMBus Controller
:(32902:7190:4133:1294) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 4
:(32902:7184:4133:1294) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 1
:(32902:7186:4133:1294) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 2
:(4098:26433:4133:1294) pci, fglrx_pci, VIDEO, NI Whistler [AMD Radeon HD 6600M Series]
:(32902:7200:4133:1294) pci, snd_hda_intel, MULTIMEDIA, 6 Series/C200 Series Chipset Family High Definition Audio Controller
:(4098:43664:4133:1294) pci, snd_hda_intel, MULTIMEDIA, N/A
:(5772:46:4187:57396) pci, ath9k, NETWORK, AR9287 Wireless Network Adapter (PCI-Express)
:(6505:4227:4133:1294) pci, atl1c, ETHERNET, AR8151 v2.0 Gigabit Ethernet
:(4147:404:4133:1294) pci, xhci_hcd, USB, uPD720200 USB 3.0 Host Controller
:(32902:7171:4133:1294) pci, ahci, STORAGE, 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller
:(32902:7213:4133:1294) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2
:(32902:7206:4133:1294) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1
:(32902:260:4133:1294) pci, None, HOST/PCI, 2nd Generation Core Processor Family DRAM Controller
:(32902:7226:4133:1294) pci, None, SIMPLE, 6 Series/C200 Series Chipset Family MEI Controller #1
:(32902:257:4133:1294) pci, pcieport, PCI/PCI, Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda1 / ext4 4096 4096 6519112 4475400 4410138 1638400 1405998 1405998
:/dev/sda2 /home ext4 4096 4096 3954445 3607287 3408887 993568 986227 986227
:/dev/sda3 WITHHELD fuseblk 4096 4096 167065599 89406805 89406805 357659988 357635247 357635247
:
Comment 1 Skouloudakis.P 2012-06-10 13:23:40 EDT
Created attachment 590766 [details]
File: backtrace
Comment 2 Skouloudakis.P 2012-06-10 13:23:44 EDT
Created attachment 590767 [details]
File: maps
Comment 3 Skouloudakis.P 2012-06-10 13:23:48 EDT
Created attachment 590768 [details]
File: dso_list
Comment 4 Skouloudakis.P 2012-06-10 13:23:50 EDT
Created attachment 590769 [details]
File: build_ids
Comment 5 Thomas Spura 2012-06-10 15:36:44 EDT
Thanks for the bug report.

This bug shows another way to reproduce the missing EINVAL value of dbus.

*** This bug has been marked as a duplicate of bug 827658 ***

Note You need to log in before you can comment on or make changes to this bug.