Bug 830569 - SELinux is preventing /usr/sbin/ldconfig from 'write' accesses on the directory etc.
SELinux is preventing /usr/sbin/ldconfig from 'write' accesses on the directo...
Status: CLOSED DUPLICATE of bug 830570
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:862d99e66a250dc3c2f5ac2d249...
:
: 980786 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-10 13:34 EDT by jj424
Modified: 2013-07-03 07:38 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-11 05:37:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jj424 2012-06-10 13:34:58 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.4.0-1.fc17.x86_64
time:           Sun 10 Jun 2012 10:34:40 AM PDT

description:
:SELinux is preventing /usr/sbin/ldconfig from 'write' accesses on the directory etc.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that ldconfig should be allowed write access on the etc directory by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep ldconfig /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:ldconfig_t:s0
:Target Context                system_u:object_r:initrc_tmp_t:s0
:Target Objects                etc [ dir ]
:Source                        ldconfig
:Source Path                   /usr/sbin/ldconfig
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           glibc-2.15-37.fc17.x86_64
:Target RPM Packages           filesystem-3-2.fc17.x86_64
:Policy RPM                    selinux-policy-3.10.0-128.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.4.0-1.fc17.x86_64 #1 SMP Sun
:                              Jun 3 06:35:17 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    Sun 10 Jun 2012 10:31:18 AM PDT
:Last Seen                     Sun 10 Jun 2012 10:31:18 AM PDT
:Local ID                      701dfab4-f837-4ac0-bb51-4b7d432fbbc1
:
:Raw Audit Messages
:type=AVC msg=audit(1339349478.590:257): avc:  denied  { write } for  pid=12176 comm="ldconfig" name="etc" dev="dm-1" ino=417889 scontext=system_u:system_r:ldconfig_t:s0 tcontext=system_u:object_r:initrc_tmp_t:s0 tclass=dir
:
:
:type=SYSCALL msg=audit(1339349478.590:257): arch=x86_64 syscall=open success=no exit=EACCES a0=1a508a0 a1=20241 a2=180 a3=4b9efc items=0 ppid=2909 pid=12176 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=ldconfig exe=/usr/sbin/ldconfig subj=system_u:system_r:ldconfig_t:s0 key=(null)
:
:Hash: ldconfig,ldconfig_t,initrc_tmp_t,dir,write
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Miroslav Grepl 2012-06-11 05:37:52 EDT

*** This bug has been marked as a duplicate of bug 830570 ***
Comment 2 Miroslav Grepl 2013-07-03 07:38:08 EDT
*** Bug 980786 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.