Bug 830574 - [rhevm] rhev-h 6.3 registration fails as it tries to fetch rhevm.ssh.key.txt while installer generates only engine.ssh.key.txt
[rhevm] rhev-h 6.3 registration fails as it tries to fetch rhevm.ssh.key.txt ...
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-setup (Show other bugs)
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Juan Hernández
Pavel Stehlik
: TestBlocker
: 808876 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2012-06-10 13:47 EDT by Haim
Modified: 2016-02-10 14:21 EST (History)
8 users (show)

See Also:
Fixed In Version: si6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-12-04 15:00:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Haim 2012-06-10 13:47:28 EDT
Description of problem:

trying to register RHEV-H 6.3 node to RHEVM and it fails with the following log:

MainThread::DEBUG::2012-06-10 21:01:32,930::deployUtil::1265::root::getRemoteFile start. IP = port = 80 fileName = "/rhevm.ssh.key.txt"
MainThread::DEBUG::2012-06-10 21:01:32,932::deployUtil::1285::root::/rhevm.ssh.key.txt failed in HTTPS. Retrying using HTTP.
Traceback (most recent call last):
  File "/usr/share/vdsm-reg/deployUtil.py", line 1280, in getRemoteFile
  File "/usr/share/vdsm-reg/deployUtil.py", line 1124, in getSSLSocket
  File "/usr/lib64/python2.6/ssl.py", line 338, in wrap_socket
  File "/usr/lib64/python2.6/ssl.py", line 120, in __init__
  File "/usr/lib64/python2.6/ssl.py", line 279, in do_handshake
SSLError: [Errno 1] _ssl.c:490: error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol
MainThread::ERROR::2012-06-10 21:01:32,936::deployUtil::1310::root::Failed to fetch /rhevm.ssh.key.txt status 404

as you can see, it tries to download rhevm.ssh.key.txt and fails on 404 (file not found).

on rhevm machine, the only ssh key file that gets generated during installation is:




for sure, its RHEVM bug (installer) since, we support both 3.0 and 3.1 hosts, also, deployUtil is set to accept the following dict:

REMOTE_SSH_KEY_FILE = ('/engine.ssh.key.txt', '/rhevm.ssh.key.txt')
Comment 2 Itamar Heim 2012-06-10 15:59:48 EDT
I'd say we are missing a symbolic link, but it won't do anyway...
Comment 3 Juan Hernández 2012-06-11 04:37:36 EDT
I think this was solved with the changes introduced for Fedora 17, as the server accepts both URLs now. See the following commit:


Take into account that there is still one file only, engine.ssh.key.txt, but the server understands both URLs. To verify it type these URLs in your browser, both should give exactly the same result:

Comment 4 Alex Lourie 2012-07-09 11:01:15 EDT
*** Bug 808876 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.