Bug 830588 - SELinux is preventing wine-preloader from mmap_zero access on the memprotect
SELinux is preventing wine-preloader from mmap_zero access on the memprotect
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
16
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
:
: 877417 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-10 15:41 EDT by morgan read
Modified: 2012-11-20 04:48 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-11 05:35:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log of abrt on selinuxtroubleshoot (6.31 KB, text/x-log)
2012-06-10 15:41 EDT, morgan read
no flags Details

  None (edit)
Description morgan read 2012-06-10 15:41:53 EDT
Created attachment 590788 [details]
log of abrt on selinuxtroubleshoot

Description of problem:
setroubleshoot keeps throwing alerts on wine

Version-Release number of selected component (if applicable):
I can't find a package selinux...

How reproducible:
Keeps on happening - don't know why.  Wasn't even running wine this time

Steps to Reproduce:
1. Install selinux (permissive)
2. Install wine
3. wait
  
Actual results:
selinux alerts

Expected results:
no selinux alerts

Additional info:
abrt.log attached
Comment 1 Miroslav Grepl 2012-06-11 05:35:38 EDT
The allert tells you what to do. mmap_zero is pretty dangerous.

If wine works fine, you can ignore it. If not, you will need to turn on the boolean.
Comment 2 morgan read 2012-06-11 06:15:53 EDT
Happy to accept it's not a bug with selinux, I suspected as much - but, if mmap_zero is pretty dangerous, then it must be a bug with wine: whether it works fine or not?

Any reason not to file this against wine?

Thanks.
Comment 3 Daniel Walsh 2012-06-11 09:09:58 EDT
No although I would guess they will close it as cantfix or wontfix, since it is pretty low functionality to deal with old windows applications.
Comment 4 Andreas Bierfert 2012-11-20 04:48:55 EST
*** Bug 877417 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.