Bug 830595 - ghc-7.4.2 is available
ghc-7.4.2 is available
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ghc (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jens Petersen
Fedora Extras Quality Assurance
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-10 15:57 EDT by Upstream Release Monitoring
Modified: 2012-11-19 01:09 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-19 01:09:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Upstream Release Monitoring 2012-06-10 15:57:42 EDT
Latest upstream release: 7.4.2
Current version in Fedora Rawhide: 7.4.1
URL: http://haskell.org/ghc/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring
Comment 1 Jens Petersen 2012-06-11 03:34:55 EDT
I would like to include 7.4.2 in Fedora 18 but going to wait
a bit to see if the Haskell Platform schedule might be improved
to make an earlier release of 2012.4.
Comment 2 Jens Petersen 2012-08-24 06:17:34 EDT
ghc-7.4.2 is now committed into the ghc master branch for f19.
Comment 3 Jens Petersen 2012-08-24 07:02:08 EDT
Scratch build: http://koji.fedoraproject.org/koji/taskinfo?taskID=4419354

I plan to build for f19 next week.
Comment 4 Jens Petersen 2012-08-27 04:31:05 EDT
On the other hand 7.6.1 rc1 is out and it would be nice to know
which version of ghc the next Haskell Platform will ship.
Comment 5 Jens Petersen 2012-09-07 02:40:07 EDT
7.6.1 was released and it seems likely that HP 2012.4 will ship with it.

At least 7.4.2 could be used to bootstrap 7.6.1.
Comment 6 Jens Petersen 2012-09-09 23:41:10 EDT
I will close this bug once it is confirmed that HP-2012.4 will ship 7.6.1.
Comment 7 Jens Petersen 2012-10-15 23:08:15 EDT
Actually it seems I was over-enthusiastic: HP-2012.4 is targetting 7.4.2.
So this is our next stop.
Comment 8 Jens Petersen 2012-11-19 01:09:22 EST
ghc-7.4.2 is in F19 Rawhide now.

Note You need to log in before you can comment on or make changes to this bug.