This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 830603 - ValueError: not enough space in VG
ValueError: not enough space in VG
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
abrt_hash:4e2c97d0cbcdc11cc0de161e5c3...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-10 16:49 EDT by Joel C Ewing
Modified: 2012-10-23 12:07 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-23 12:07:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb-WQSvg0 (974.79 KB, text/plain)
2012-06-10 16:49 EDT, Joel C Ewing
no flags Details

  None (edit)
Description Joel C Ewing 2012-06-10 16:49:34 EDT
libreport version: 2.0.10
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/loop3 --lang en_US.UTF-8
executable:     /sbin/anaconda
exnFileName:    /tmp/anaconda-tb-WQSvg0
hashmarkername: anaconda
kernel:         3.3.4-5.fc17.x86_64
other involved packages: 
product:        Fedora
release:        Fedora release 17 (Beefy Miracle)
time:           Sun 10 Jun 2012 03:48:37 PM CDT
version:        17

anaconda-tb-WQSvg0: Text file, 998187 bytes

description:
:The following was filed automatically by anaconda:
:anaconda 17.29 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/lvm_dialog_gui.py", line 54, in getTempVG
:    raise ValueError("not enough space in VG")
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/lvm_dialog_gui.py", line 69, in computeSpaceValues
:    vg = self.getTempVG()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/lvm_dialog_gui.py", line 965, in updateVGSpaceLabels
:    (total, used, free, snapshots, reserved) = self.computeSpaceValues()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/lvm_dialog_gui.py", line 1580, in __init__
:    self.updateVGSpaceLabels()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/partition_gui.py", line 1777, in editLVMLogicalVolume
:    lv.vg, isNew = False)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/partition_gui.py", line 1668, in editCB
:    self.editLVMLogicalVolume(lv = device)
:ValueError: not enough space in VG

environ:
:LC_NUMERIC=C
:LIBUSER_CONF=/tmp/libuser.8ClGkl
:LVM_SUPPRESS_FD_WARNINGS=1
:LOGNAME=root
:USER=root
:GCONF_GLOBAL_LOCKS=1
:PATH=/sbin:/usr/sbin:/usr/sbin:/usr/bin:/sbin:/bin:/root/bin:/sbin:/usr/sbin
:PIXMAPPATH=/tmp/updates/pixmaps/:/tmp/updates/:/tmp/product/pixmaps/:/tmp/product/:pixmaps/:/usr/share/anaconda/pixmaps/:/usr/share/pixmaps/:/usr/share/anaconda/:/usr/share/python-meh/:/usr/share/icons/Fedora/48x48/apps/
:HOME=/tmp
:DISPLAY=:0
:ANACONDA_PRODUCTNAME=Fedora
:LANG=en_US.UTF-8
:TERM=dumb
:SHELL=/bin/bash
:TZ=America/Chicago
:XAUTHORITY=/root/.xautharFsRe
:GLADEPATH=/tmp/updates/:/tmp/updates/data/ui/:ui/:/usr/share/anaconda/ui/:/usr/share/python-meh/
:SHLVL=1
:GNOME_DISABLE_CRASH_DIALOG=1
:ANACONDA_PRODUCTVERSION=17
:ANACONDA_BUGURL=https://bugzilla.redhat.com/bugzilla/
:USERHELPER_UID=1000
:ANACONDA_ISFINAL=true
:_=/sbin/anaconda
:PWD=/home/liveuser
:DESKTOP_STARTUP_ID=userhelper/Starting Install to Hard Drive/1269-0-localhost.localdomain_TIME0
Comment 1 Joel C Ewing 2012-06-10 16:49:38 EDT
Created attachment 590793 [details]
File: anaconda-tb-WQSvg0
Comment 2 Joel C Ewing 2012-06-10 17:08:10 EDT
Occurred when doing Custom Disk Configuration and attempting to edit a logical volume to assign it to the install process.  When logical volumes and partitions are being manually assigned for the install, it might make sense for anaconda to verify that the assigned volumes have sufficient space for their intended function, but it makes no sense to perform space checks on the volume group unless anaconda is being asked to create a new logical volume.

The volume group only contains 13GB free space, but there are existing old LV's of 27GB to be used for root and 5.5GB for swap.  There are also other LV's present, including a snapshot LV, but none of these will be selected for the install.

The failure message appears identical with earlier bugs, but these claim to have been fixed prior to the anaconda-17.29-1 on the install CD/DVD iso image.
Comment 3 Brian Lane 2012-10-23 12:07:05 EDT
This code has changed considerably. Please re-test using Anaconda 18.X and open a new bug if it is still a problem.

Note You need to log in before you can comment on or make changes to this bug.