Bug 830612 - vi not usable
vi not usable
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-10 21:11 EDT by John Mellor
Modified: 2014-01-21 18:22 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-21 15:44:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Mellor 2012-06-10 21:11:40 EDT
Description of problem:
System upgraded from f16 to f17.  vi is aliased to vim, which for some weird reason has a missing dependency on libruby (!!!)

Version-Release number of selected component (if applicable):
vim-enhanced-7.3.515-2.fc16.x86_64

How reproducible:
Every time.

Steps to Reproduce:
1. Upgrade f16 to f17.
2. Normal user login.  System is bog-standard.
3. vi some file.  Note vim error error.
  
Actual results:
$ vim xxx
vim: error while loading shared libraries: libruby.so.1.8: cannot open shared object file: No such file or directory

Expected results:
File xxx should be opened for edit in vi or vim.

Additional info:
Comment 1 John Mellor 2012-06-11 21:37:13 EDT
Please transfer this problem to the Fedora installer.  The root cause of this bug appears to be that the installer on the F17 DVD does not upgrade the vim-common, minimal and enhanced packages, but simply installs the F17 vim packages alongside the F16 one.  This leaves the F16 products installed, causing lots of grief for a subsequent yum update step.
Comment 2 James Antill 2013-05-21 15:44:33 EDT
 yum can't do much at this point, "yum check" can point out what is wrong, but that's about it.

Note You need to log in before you can comment on or make changes to this bug.