Bug 830618 - Kdewebdev (quanta) hangs in F17
Kdewebdev (quanta) hangs in F17
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kdelibs3 (Show other bugs)
17
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kevin Kofler
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-10 22:06 EDT by A. Mani
Modified: 2012-06-13 17:38 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-13 17:38:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description A. Mani 2012-06-10 22:06:51 EDT
Description of problem:
Quanta hangs after a file is opened and browsed with mouse.

Version-Release number of selected component (if applicable):

3.5.10 in F17 
KDE-4.8.3

How reproducible:


Steps to Reproduce:
1.start
2.open html file
3.browse
  
Actual results:


Expected results:


Additional info: gdb 

__________________________QChar::Separator_Paragraph;
(gdb) bt
#0  isSpace (ch=...) at tools/qunicodetables_p.h:219
#1  QChar::isSpace (this=0xbe2242) at tools/qstring.cpp:475
#2  0x00007ffff074a321 in KateRenderer::textWidth (this=0x15dd7d0, 
    textLine=..., startcol=startcol@entry=0, maxwidth=maxwidth@entry=712, 
    needWrap=needWrap@entry=0x7fffffffcdf8, endX=endX@entry=0x7fffffffcdec)
    at katerenderer.cpp:806
#3  0x00007ffff07a1908 in KateViewInternal::range (this=this@entry=0x1599c60, 
    realLine=17, previous=previous@entry=0x0) at kateviewinternal.cpp:1331
#4  0x00007ffff07a2b78 in KateViewInternal::range (this=0x1599c60, 
    realCursor=...) at kateviewinternal.cpp:1403
#5  0x00007ffff0794190 in KateViewInternal::updateView (
    this=this@entry=0x1599c60, changed=changed@entry=false, 
    viewLinesScrolled=viewLinesScrolled@entry=3) at kateviewinternal.cpp:525
#6  0x00007ffff07a5852 in KateViewInternal::scrollPos (
    this=this@entry=0x1599c60, c=..., force=force@entry=false, 
    calledExternally=calledExternally@entry=false) at kateviewinternal.cpp:425
#7  0x00007ffff07a5bde in KateViewInternal::scrollViewLines (
    this=this@entry=0x1599c60, offset=<optimized out>)
    at kateviewinternal.cpp:335
#8  0x00007ffff07a5d3f in KateViewInternal::wheelEvent (this=0x1599c60, 
---Type <return> to continue, or q <return> to quit---
    e=<optimized out>) at kateviewinternal.cpp:3274
#9  0x0000003c4cf85dba in QWidget::event (this=0x1599c60, e=0x7fffffffd370)
    at kernel/qwidget.cpp:4717
#10 0x0000003c4cf018ad in QApplication::internalNotify (this=<optimized out>, 
    receiver=0x1599c60, e=0x7fffffffd370) at kernel/qapplication.cpp:2645
#11 0x0000003c4cf01eaa in QApplication::notify (this=0xb8d7f0, 
    receiver=0x1599c60, e=0x7fffffffd370) at kernel/qapplication.cpp:2465
#12 0x0000003c4d9a8690 in KApplication::notify (this=0xb8d7f0, 
    receiver=0x1599c60, event=0x7fffffffd370) at kapplication.cpp:550
#13 0x0000003c4ce9ed91 in sendSpontaneousEvent (event=0x7fffffffd370, 
    receiver=0x1599c60) at kernel/qapplication.h:526
#14 QETWidget::translateWheelEvent (this=this@entry=0x1599c60, global_x=704, 
    global_y=367, delta=-120, state=state@entry=0, orient=Qt::Vertical)
    at kernel/qapplication_x11.cpp:4365
#15 0x0000003c4ceac55d in QETWidget::translateMouseEvent (
    this=this@entry=0x1599c60, event=event@entry=0x7fffffffd950)
    at kernel/qapplication_x11.cpp:4166
#16 0x0000003c4ceab34b in QApplication::x11ProcessEvent (this=0xb8d7f0, 
    event=0x7fffffffd950) at kernel/qapplication_x11.cpp:3606
#17 0x0000003c4ceba224 in QEventLoop::processEvents (this=0xbe4950, flags=4)

_______________________________
Comment 1 Kevin Kofler 2012-06-11 18:07:25 EDT
This is most likely a bug in kdelibs3 or even qt3. I'm trying to figure out what's going wrong, though it's hard because I can't reproduce this on my primary machine, which is still running F15. I suspect something may be getting miscompiled with the new g++ in F17.
Comment 2 Kevin Kofler 2012-06-11 18:25:41 EDT
Looks like this is the same as:
http://bugs.trinitydesktop.org/show_bug.cgi?id=979

According to:
http://bugs.trinitydesktop.org/show_bug.cgi?id=979#c19
rebuilding kdelibs3 with the latest F17 GCC (kdelibs3-3.5.10-35.fc17 was built with gcc-4.7.0-0.20.fc17 (a prerelease), current in F17 and Rawhide is gcc-4.7.0-5.fc17) might fix it. I'll have a try.
Comment 3 Fedora Update System 2012-06-11 20:36:37 EDT
kdelibs3-3.5.10-37.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kdelibs3-3.5.10-37.fc17
Comment 4 Fedora Update System 2012-06-13 17:38:15 EDT
kdelibs3-3.5.10-37.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.