Bug 830624 - [Patch] Make RHEL's version not embedded in client entitlement rpms
[Patch] Make RHEL's version not embedded in client entitlement rpms
Status: CLOSED ERRATA
Product: Red Hat Update Infrastructure for Cloud Providers
Classification: Red Hat
Component: RHUA (Show other bugs)
2.1
Unspecified Unspecified
high Severity unspecified
: ---
: ---
Assigned To: mkovacik
mkovacik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-10 23:22 EDT by Satoru SATOH
Modified: 2012-08-24 09:27 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Client entitlement RPMs filenames generated with rhui-manager contain "el6" which gives the impression that the RPMs are only built for RHEL 6 clients but the RPMs are actually built for both RHEL 5 and 6 clients. The abbreviation "el6" has been removed from the filenames for client entitlement RPMs to prevent the confusion.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-24 07:54:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
made '%{dist}' not embedded in %{release} in client entitlement rpms' template (730 bytes, patch)
2012-06-10 23:22 EDT, Satoru SATOH
no flags Details | Diff
Verifying screen log (37.90 KB, text/plain)
2012-07-26 12:16 EDT, mkovacik
no flags Details

  None (edit)
Description Satoru SATOH 2012-06-10 23:22:04 EDT
Created attachment 590808 [details]
made '%{dist}' not embedded in %{release} in client entitlement rpms' template

Description of problem:

Client entitlement rpms generated with rhui-manager contain abbreviated 
RHEL's major version (%{dist}, "el6") in these names such as:

  rhui-client-entitlement-rhui-2.0-2.0-1.el6.noarch.rpm
                                         

This filename indicates that this rpm is built for RHEL 6 only
although it's for both RHEL 5 and 6 client guests.


IMHO, it should be better not adding '.el6' in rpm names simply.


Version-Release number of selected component (if applicable):
rh-rhui-tools-2.0.64-1.el6_2
Comment 1 James Slagle 2012-06-21 10:31:21 EDT
thanks for the patch. I've applied this to our cloude repo as commit 
9aa0c9b67a2c80f25038dd475c2b938e3161351a
Comment 2 mkovacik 2012-07-26 12:16:56 EDT
Created attachment 600551 [details]
Verifying screen log

Verified in version: RHEL-6.3-RHUI-2.1-20120719.0-Server-x86_64-DVD1.iso. See the attached screen log.
Comment 3 sachua 2012-08-14 23:07:56 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Client entitlement RPMs filenames generated with rhui-manager contain "el6" which gives the impression that the RPMs are only built for RHEL 6 clients but the RPMs are actually built for both RHEL 5 and 6 clients. The abbreviation "el6" has been removed from the filenames for client entitlement RPMs to prevent the confusion.
Comment 5 errata-xmlrpc 2012-08-24 07:54:57 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1205.html

Note You need to log in before you can comment on or make changes to this bug.