Bug 830731 - Performance issue with creating external web service client
Performance issue with creating external web service client
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise SOA Platform 5
Classification: JBoss
Component: riftsaw (Show other bugs)
5.3.0 GA
Unspecified Unspecified
unspecified Severity unspecified
: ER5
: 5.3.0 GA
Assigned To: Gary Brown
Ivo Bek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-11 06:11 EDT by Gary Brown
Modified: 2014-10-15 13:25 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
There was a performance issue when creating an external web service client. Users who attempted to run a quickstart to accomplish this encountered performance problems. This was due to caching dispatcher issues. The problem has been addressed and performance should no longer be compromised in these instances.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-15 13:25:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker RIFTSAW-497 Major Resolved Performance issue in WebServiceClient 2012-07-24 07:35:59 EDT

  None (edit)
Description Gary Brown 2012-06-11 06:11:26 EDT
Description of problem:

Performance regression has been introduced between 5.2.GA and the latest engineering build for 5.3. The area of concern identified by Tom Cunningham is the WebServiceClient.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Deploy simple invoke quickstart
2. Run 'x' tests
  
Actual results:


Expected results:


Additional info:
Comment 1 JBoss JIRA Server 2012-06-11 06:21:21 EDT
Gary Brown <gary.pi4tech@gmail.com> updated the status of jira RIFTSAW-497 to Resolved
Comment 2 Gary Brown 2012-06-11 06:25:29 EDT
Fixed for riftsaw 2.3.5.Final tag.
Comment 3 Suz 2012-07-16 20:38:01 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
There was a performance issue when creating an external web service client. Users who attempted to run a quickstart to accomplish this encountered performance problems. This was due to caching dispatcher issues. The problem has been addressed and performance should no longer be compromised in these instances.
Comment 4 Ivo Bek 2012-07-24 07:35:53 EDT
Verified in JBoss SOA-P 5.3.0.CR1

Note You need to log in before you can comment on or make changes to this bug.