Bug 830744 - anaconda should implicitly run "rpmdb --rebuilddb"
anaconda should implicitly run "rpmdb --rebuilddb"
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-11 06:28 EDT by Nick Coghlan
Modified: 2013-01-20 12:40 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-20 12:40:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nick Coghlan 2012-06-11 06:28:22 EDT
Description of problem:

Attempts to upgrade my Fedora 16 installation to Fedora 17 were failing: anaconda would bail during the upgrade process, complaining about being unable to find an .fc15 RPM (for "mythes")

Initially I chalked the problem up to something going wrong with preupgrade, but then upgrading with the DVD also failed with the same error.

Since the reference to an fc15 RPM seemed suspicious, I then ran "rpmdb --rebuilddb" before trying preupgrade again, and that time it worked.

Version-Release number of selected component (if applicable):

anaconda-17.29-1.fc17.x86_64 (I think - that's the version I currently have installed, and it doesn't appear to have been updated since the F17 release)

How reproducible:

Completely consistent until I ran "rpmdb --rebuilddb" to fix what was presumably a stale reverse index entry, or some other problem that had been lingering in the RPM database for a while without causing any obvious harm

Steps to Reproduce:
1. Have a latent issue in your RPM database
2. Try to use preupgrade or the DVD to upgrade F16 to F17

Actual results:

Anaconda will throw an exception during the upgrade process (leaving an intact F16 system in place)

Expected results:

Anaconda can cope with a previously undiagnosed minor glitch in the RPM database (e.g. by always running the equivalent of "rpmdb --rebuildb" when upgrading an existing installation)

Additional info:

Kudos to anaconda for at least bailing out cleanly and not harming the existing F16 installation when the upgrade failed.

The reason I'm filing this as an anaconda bug is because it *was* possible to eliminate the problem through an automated fix - all I had to do was run "rpmdb --rebuilddb" and the upgrade subsequently worked. It seems like it should be possible to build that into anaconda so it isn't relying on potentially stale cached data for upgrades.
Comment 1 Fedora End Of Life 2013-01-16 05:14:05 EST
This message is a reminder that Fedora 16 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 16. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '16'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 16's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 16 is end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" and open it against that version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Chris Lumens 2013-01-20 12:40:22 EST
With F18, we've moved to a simpler upgrade process that does not involve anaconda in the least.  We're using a tool called fedup now that takes the place of preupgrade, and then uses regular system tools to do the upgrade itself.  With anaconda no longer involved, this bug report should no longer be relevant.

Note You need to log in before you can comment on or make changes to this bug.